Windows Cannot Access WDMyCloud


I just got a 4TB My Cloud, and have only had semi-success setting it up.  I’m on a laptop running Windows 7.

I can access the dashboard via my web browsers (Firefox, Chrome) just fine.  I downloaded the WD Quick View, it sees the My Cloud just fine.  Installed the app on my (Android) phone, which also sees the My Cloud just fine.  

However, any attempts to map to WDMyCloud via Windows Explorer or via the Quick View result in the error “Windows Cannot Access WDMyCloud.”  The error code, when I click details, is 0x80070043 - “The network name cannot be found.”

When I’m in Windows Explorer, and I click on “Network,” WDMyCloud appears twice - as a Media Device and as Storage.  Clicking on Media Device brings up Windows Media Player, and all of the music on my PC.  I see WDMyCloud as a remote library, I click on it, and it tells me (correctly) that there are no media files in the remote library.  

But when I click on the icon that is under Storage, nothing happens.  If I right click on it, and choose “View Device Webpage,” I get the dashboard, as expected.  But no other options do anything.

When I first set up the thing, I tried using the installation program from WD.  It gave me an error that I may not be able to set up shared folders.  At the time, I had sharing turned off on my PC, but I have since turned it on.  This was of no help, despite rebooting.

The laptop and the My Cloud are on the same work group.

I am at my wit’s end.  Clearly the thing is connected, as the laptop can see and interact with the dashboard, as well as the Android phone (oh, and the Android tablet, too, which I neglected to mention above).  It’s just Windows that’s being stubborn.

My best guess is that this is related to Norton 360, but I haven’t the faintest idea which setting needs to be changed to fix this issue.  Plus, Googling My Cloud and Norton 360 only yields questions about using Norton 360 to do the backup, and I am not that far yet.  I would think if this were an issue, there would be multiple hits, but Google has failed me before, snicker.

I am not doing anything fancy here.  Just trying to connect a Windows 7 PC to a WD My Cloud via Windows Explorer and a wireless network.  

ETA: I have updated to the latest firmware.  No help.




Do you have Network Discovery Enabled?

Link on “Howto”

Yes, I do.

Have you tried unplugging the power to your router at the router, wait a minute and then plug it back in? Do that and then see if the WD My Cloud is recognized.

I am adding to this as I have been working on my laptop and I hope what I found will help you. Click on Start>Control Panel>Network and Internet>Network and Sharing Center then See full map. WDMYCLOUD should show in this. See image below. If it is there then right click on it and click open.

A pop-up may appear asking you to sign in. See image below. If it does use your network user name and password, not those for the WD My Cloud. For those non-believers I did a PSR on this!!

All my shares opened. See image below.

Hope this helps.

You should probably take a close look at the Norton 360 firewall.  I suggest temporarily disabling the firewall to see if that solves the problem.

Thanks!  I hadn’t thought of unplugging the router, but I just tried, and it didn’t help :frowning:

The network map illustrates the oddity of this situation.  The WDMyCloud indeed appears on it.  It also appears if I click “Network” in Windows Explorer.   However, clicking on WDMyCloud does absolutely nothing.  The only option from the right-click menu that does anything is the one to view the device home page.

It’s a conspiracy between my computer and WD to drive me absolutely bonkers!  :laughing:

It does seem like this has to be it.  However, I disabled both Norton’s firewall and its anti-virus protection, but still no luck.

What I did not do was reboot after disabling.  I don’t think it would have made a difference.



It was… a lot of things conspiring to drive me crazy prevent access to my drive.

  • In a misguided attempt to speed things up on a seemingly slow computer (long before getting the My Cloud), I had disabled some services.  Turns out some of them were kind of important for this kind of thing.   This alone did not fix the problem, however, so maybe that wasn’t it after all.  Snicker.
  • Norton’s settings were all correct… except, I had it thinking I was on a public network.  By default, in a public network, it blocks sharing.  Changing it to a home network was necessary.   However, things still didn’t work properly.  Yet.
  • I thought it was my router firewall until I pulled out an old XP laptop, which found the thing right away.  So much for that thought.
  • Tried various other things to no avail.  No, I’m not listing them, because I cannot remember them all.
  • What finally fixed it was changing my “provider order” in my network adapter settings.  It’s here in Rick Strahl’s Web Log.  The whole registry part described on that website was not applicable, since I’m on my home network and not, well, on UNC’s network.  However, the bit under the “Provider Order Dialog” heading did the trick.  I moved Microsoft Windows Network to the top, rebooted, and, voila!

Of course now I’m told “Audio Service is not running,” which has nothing to do with networking, so I have no idea what I did there.  But I bet fixing that’s going to be a heck of a lot easier than finding the culprit above.

Thanks to those who tried to help!

… and the Audio Service thing just required a reboot :wink: