Windows cannot access : The remote device or resource won't accept the connection

Good evening all,

I have 2 units of MBL; 2TB and 3TB respectively connected to my home network. I encounter the same problem with both units when the only thing that was changed was the internet provider which was switch from one company to another but then both uses the same infrastructural connection.

Initially, the 2TB WDL gave me this problem when I tried accessing it through the desktop while the 3TB was OK. After awhile, it was the other way round where the 3TB is giving me this problem and the 2TB is working fine. I am able to access both unit dashboard and both units are showing up on my home network. When I tried using the WDTV, it could not even detect that particular storage space when one of it had that problem.

My desktop is running on Windows 7 Home Premium; any advise would be highly appreciated.


As a recommendation, try configuring the units with static IP’s address. It’s probably that the change on the service provider might change the ip on the units or the router.

Also have you tried resetting the units.