Windows cannot access MyBook live error

I tried searching the forums and didn’t find anything I haven’t tried.

When trying to access the public share on my 3TB  I get a Windows cannot access error. I am able to access the dashboard without any issues but cannot access the shares through QuickView, Explorer, direct IP, or dashboard. If I use the dashboard to restart the MBL, I can access the shares again once it comes up but after an hour or so of no activity, I get the same message. I have disabled sleep and all power save features but it still occurs. FW is 02.43.03-022.

Would a FW rollback help with this? It has been happening intermittently for the last 6 months or more.

Thanks in advance.


Have you tried setting a Static IP? 

Have tried both static and dynamic, prefer static for mapping. I made sure that the DNS servers were added as well. It will work fine after a restart for a few minutes to a couple of hours, after that I have to restart the MBT again. I have completely rebuilt my network after upgrading my routers firmware and it did not help.

I’m having pretty much the same problem except when the connection drops even the dashboard isn’t available.

Today the connection drops when I try to transfer files to the drive pretty much rendering my drive rather useless. I have put in three support tickets over the last 6 weeks without any success at resolution. This is getting very frustrating.

Over the last few weeks it seemed to be better, only needing me to restart every 4-5 days. Today, I get home from work and I’ve restarted it 5 times and it still will not allow me to access it through my network or mapped drive. I can still get to the Dashboard without any problems but cannot access the drive through Explorer or Quick View or other means to get to the files. It is now asking for username/password when trying to Open through Quick View and it never did that before, but it just rejects the correct information anyway.

After multiple restarts in Dashboard and unplugging the MBL and restarting a few more times after it came back up, I’m able to again access my files. Think it is time to get them off this drive and avoid all WD network drives for a while since they can’t seem to get the stability needed for even simple home access. Maybe I’ll just deal with the slow USB port on my router to access for a while.