Windows cannot access any shares but dashboard is fine

I recently performed a full reset of my 2Tb My Cloud drive, and can now access the dashboard again. However, every time I try to access the shares through windows explorer on my 2 windows 10 machines they say they can’t find it.

The NAS has a reserved DHCP address on my router, and the dashboard, ssh and ftp work fine but I would like to be able to map the network drive like I could before. I’ve already tried the suggestions in the sticky but no luck. Anyone else have this problem and fix it?

What is the exact error message that Windows 10 displays when it is unable to access the shares?

Things to check. Are the inaccessible shares set to private? Can the Public share be accessed? Can other non Windows 10 devices access the shares the Windows 10 computer cannot access?

Also, the diagnostic tool that pops up says it has no idea what the problem is.

I have 1 private share and the public share, neither of which can be accessed, except by FTP. My android phone can access them no problem.

What “diagnostic tool” is popping up?

Again, what is the exact wording of Windows 10 error message that appears on screen when one clicks on a Share using Windows File Explorer? The details of that error message will often point the way on what the potential problem may be and how to fix or correct it.

Other ways to try and access the My Cloud, use the IP address for the My Cloud rather than the name in Windows File Explorer (example: \ Also carefully read through the stickied thread Compilation of Windows 10 Methods, Steps and Solutions again just in case something was missed. Some of the procedures can be a bit confusing.

I have been through the sticky, but alas am still unable to access the shares.

Try the following. Turn off the computer, the router and the My Cloud. Then turn on the router and wait for it to fully boot up. Then turn on the My Cloud and wait till it shows a blue LED on the front LED light. Then turn on the computer and let it load Windows. Then try again.

If that doesn’t work some other options:

Ensure Network Discovery is enabled.
Type network in the search box and choose Network and Sharing Center in the list to open it.
Next, select Change advanced sharing settings to continue.
Next, choose Turn on network discovery if not enabled , and click Save changes to save the setting.
Sometimes one has to reboot the computer after making this setting change.

If that doesn’t work, some (on earlier versions of Windows) have indicated that disabling IPv6 in computer’s Network Adapter settings sometimes solves similar problems.