Windows Backup software can't connect to EX2, but Windows can


I just bought a MyCloud EX2. But I haven’t been able to get my Windows backup software to recognize it.

What works:

On my Win 7 PC I can see the EX2 in the Network folder. It shows as a storage device

I can open the EX2 web page. I have created a user (mark) and a share (marks-quad to match my PC name)

I can browse the share from my Win7 PC (Click on icon in Network folder, enter username & password, click on share)

I have successfully run TimeMachine on a 10.9 Mac

So all good.

However, I tried using (separately) Rebit and ShadowProtect. With Rebit, the EX2 wasn’t listed as a network backup device.With ShadowProtect I try to create a destination, but I keep getting the error: The system cannot find the path specified.

I expect it is something simple, but I’m not sure how to debug it. I’m guessing that since I have the same problem with two different backup products I haven’t properly set up the EX2 to be visible in the way they need.

I’m also curious why I need to enter a username & password in Win7 in order to see the shares on the EX2. I’m pretty sure when I first set it up I didn’t need to, but at some point along the way it became required.

Any ideas?




  1. I’m not familiar with Rebit and ShadowProtect but it may be that they will not do backups from a NAS, only local disks.  That’s just a guess since that’s what I found with other backup software.  I just finished posting about this a few minutes ago so check that out, it may be helpful.

  2. MyCloud, when you are on your local network, will log in without a password if the username and password you use to log into your Windows system match the username and password on the MyCloud.  One twist which I ran into is when you are using your Microsoft Live account as your login to your PC.  The MyCloud cannot have an email address as a login name but the Microsoft Live login IS your email address.  Therefore the two will never match and the MyCloud might challenge you to log in to it with your MyCloud credentials.  Windows remembers credentials though, so it should not ask you to do this repeatedly.  If it is, you may have stored an incorrect credential and you just need to remove it.  Check out this post for info:

Thanks for the reply

Both Rebit and ShadowProtect explicitly support backing up to a network storage

I don’t use Microsoft Live

Thanks for the link to Credentials Manager. Interesting.



OK Problem solved - well stupidity and ignorance somewhat decreased :flushed:

First. I needed to use the same username and password on both my Win 7 PC and my EX2. Not doing so means whenever you open the EX2 device in Explorer you have to enter a valid EX2 username and password. Secondly, some backup products just won’t see the shares on the EX2 and don’t offer you a chance to enter the correct credentials.

Second don’t turn on Local Master Browser unless you know what you are doing. I didn’t. I was trying random things to get it working. What got me was you have to reboot the EX2 after you turn off the Local Master Browser for it to go away.

This was extremely helpful

Third, at least for Shadow Protect, I didn’t set up the destination correctly. However, once the above two points were resolved, I could browse to the share I wanted on the EX2. Only then did I see I was entering the wrong values into the wrong fields.

So backup done. Maybe these comments will help someone else.