Windows 8 PC not seeing LiveBookDuo

Until a couple of weeks ago my LiveBookDuo worked absolutely fine. I could access the drives from my Windows 8 PC.

Then my PC took an automatic update and I lost sight of the LiveBookDuo. I tried a restore, but that would not complete so it seems no way back.

I believe that the issue is with my PC as a netbook running XP sees the drives fine when connected to the network. I can also access the drive through WD2GO and the device shows and operates as a media device on my Windows 8 PC.

I have tried to use the WD setup again and get this

but am never at home within WD Service Hours!!

Iam pretty sure that it is Windows 8 that causes the problem, but I am sure that I cannot work it out.

Any clues or suggestions would be greatly appreciated.

Best regards,

Ian Sutherland.

Check the firewall and/or security settings on the Win 8 computer. 

The drive can be setup without the disc, just type //drivename and see if you can see the share folders on the unit.