Windows 8 Cannot Change Drive Name in My Computer but


When I try to change my Elements 2TB external hard drive “Name” thru right click on drive or going to drive properties, it only happens in Disk Management (in Computer Management) and still I see LOCAL DISK in My Computer (or This PC in Windows 8.1).

It only happens to one of my Elements 2TB and the others are OK. When I take that specific drive to another computer (XP or Linux), it shows the right drive name in My Computer.

This problem is reported in Internet only few times then I wonder if anyone know what causes it.

Thank you very much.

PS. I did not try Formtting the whole drive solution because it is full and it takes 24 hours to sync back data from secondary backup to this one.


I rebooted Windows 8 in Safe Mode and it shows right name in My Computer (or This PC in Windows 8.1)!!

Then whatever causing, is in my computer or OS.

Also I tried this drive in another Windows 8.1 machine and still same problem. If Windows 8.1 is causing it then why my other Elements 2TB is good with it about changing name???

I do not know if this is related, but it shares a symptom which some people attribute to Panda security software.

link from the above article, with a possible, non-format fix procedure-

1 Like

Thank you so very much!

I knew it must be because of a autorun file but I never thought about Panda software which I had on another PC, month ago, not now.

The only thing which wonders me is, Only Windows 8 (mine is 8.1 Preview) has problem with it, then it should be more Windows Problem than Panda!

Again thank you so very much. It would worth many Kudos, I gave one :slight_smile:


You are very welcome! It makes my day that a suggestion worked out. I was puzzled, too, by Win 8 being the only platform affected. That alone made me think that something else might be going on. Thanks for sharing your success!

Best Regards,


1 Like

Add Windows Vista or 7 too. There is a video in YouTube that someone talks about this problem, asking for help and his Windows is Vista or 7. I do not have them to try but I guess it should be 7.