Windows 8.1 setup on 4TB Western digital HD problem


i assembled a pc with the following spec’s:

MB Gigabyte x99 gaming g1.

HD western digital 4tb black

when booting from dvd-rom to install windows 8.1 pro 64bit, windows setup screen the available hd’s to install windows on it.

when selecting the above hd and said new, winodws setup only recognise 2.5tb from the 4 tb! and the rest is un-allocated partion and couldn’t format or use to create bootable partion.

when erasing all partions on hd, there are 2 allocated partions one 2tb, and the oher 1.6tb.

couldn’t move from here.

this problem happened on another pc with MB Gigabyte z87x-d3h and 3 tb westen digital black.

please  help

Hi there, welcome to the community, 

Did you format the drive before installing Windows? Because what you are explaining seems awefully similar as to when you format drives that are 2TB and larger in MBR instead of GPT.

If you are 100% sure that you have formatter the drive using GPT parition table, you should be able to expand the partition once the OS is installed.

when installing windows you have to create a new partition then format it. i tried before to install windows on the formated partition 2 tb out of 4 tb given by windows setup, after installing windows i already tried to expand to full 4 tb but it didn’t work!

also formating partitions when installing windows don’t gives you much of a choice of format type!!!