Windows 7 won't boot with My Book Essential 3tb drive plugged in

I read all of the posts and tried everything, changed the boot order, enabled/disabled legacy USB support, 4 hours later it still doesn’t work. Interesting to note that with the boot menu open I could move about the menus when the drive wasn’t plugged in, but as soon as I plugged it in everything would freeze. This behaviour was consistent every time I plugged/unplugged the device. This was on an hp pavilion 6202n which has a Phoenix bios from 2007. Since I only bought the drive yesterday, I will return it to Best Buy tomorrow. Too bad, my WD 2Tb drive works fine but I was looking for a good backup drive.


If you connect the drive to another computer do you experience the same issue?

Funny, the support rep at Best Buy asked me the same question… the bottom line is that I don’t want to connect it to another computer, I bought it to connect to my HP Pavilion 6202n for backup purposes and simply put, it’s incompatible. I since bought a 3Tb WD “Elements” and it works fine.  Now I just need to find a suitable backup program.