Windows 7 SP1 64 bits doesn't show MyBookWorld if I don't disable Windows Firewall (Public networks)


#1

I have Windows 7 SP1 64 bits.

Also have a WD My Book World 1 TB with firmare 01.02.06 with MioNet 4.3.1.12

Both connected to a wi-fi router Linsys WRT54G.

It use to work fine. When I was using AVG Internet Security with it’s firewall.

When AVG’s license expired, I uninstalled it and installed Microsoft Security Essentials and activated Windows 7 Firewall with it’s default settings.

Now, when I go to “Computer”, in “Network” (left panel) doesn’t show my WD My World Book.

But if I type “\MyWorldBook\Public” I can access the folder. I can link it as “Z:”

Network map shows My Book World, my PC, the Linksys router and Internet. http://tinyurl.com/3cs9qqa

What I found is, if I turn off Windows Firewall and reboot PC, I go to “Computer” and under “Network” in the left panel, I find the device “MyWorldBook” and my PC. http://tinyurl.com/3vzjo9a

If I turn on Windows Firewall, a few seconds after the “MyWorldBook” and my PC devices disappear from “Computer’s” left panel. However, mapped units works fine. Same if I type manually “\MyWorldBook\Public”.

Specifically, I have to turn off only a part of the Windows Firewall: Public Networks. Don’t know why., but if “Private” part of Windows Firewall is enabled, “MyWorldBook” device is under “Network”.

So, I think that some rule/s in “Public networks” part of Windows Firewall are interfering. The thing is, I can’t find which one.

I found this topic: http://tinyurl.com/62seyeh I think is the same problem.

Hope for any help. In the mean time, Windows Backup works fine even if the device isn’t under “Network”.


#2

Hi there, this is more common than you think. When you have the option for a Public network enabled on W7, the computer uses a higher level of security than it uses on a Private network. This is because W7 considers that Public networks are not safe, so it blocks network discovery.


#3

ThePizzaMatrix wrote:

Hi there, this is more common than you think. When you have the option for a Public network enabled on W7, the computer uses a higher level of security than it uses on a Private network. This is because W7 considers that Public networks are not safe, so it blocks network discovery.

Yeah, well… the thing is my network card is setted as “home network” and not as a “Public network”. So, why is Windows blocking network discovery? I checked and in the “home network” profile Network discovery is enabled.