Windows 7 sees my drive but cannot access it

My Book 2TB was working fine for 5-6 months. Now I cannot access my files. When its plugged in to the computer locally, it shows up as “Local Drive J” where it used to come up as “My Book” (or whatever it was).  If I click on it, Windows seems to attempt to access it for several minutes then hangs with “Not Responding”. Cannot access it via CMD or Disc Management either. Tried to upgrade firmware but that hangs too. I can hear the disc spinning, and tried a different USB cable to no avail. Also tried it on my laptop and same problem exists. HELP!! Lots of data on that drive that I need to access.

Looks like the partition is corrupted. You can use a recovery software to retrieve the files. You can also try  CHKDSK.

I have previously used  Mini Tool Partition Recovery and  Mini Tool Data Recovery

You can also search for many other utilities online.

Thanks for the reply. Before those suggestions I made sure everything else was up to date on the PC. Downloaded the recommended data recovery tools as well as a couple others and nothing is working. The Mini Tool Data Recovery gets to 62% every time and hangs there (I left it running for about 36 hours). When this WD disk is attached, Windows Explorer gets totally hosed and I’m constantly restarting the PC. 

I guess the disk is hosed, the question is, will WD fix it? Recover my data? Or am I stuck.

You could try other recovery tools, like TestDisk from CG Security.

No, WD won’t spring for recovery.  If the drive has failed, they’ll replace it, but they don’t cover data.

And, as far as I know, even if you paid for recovery out of your own pocket, the retrieved data would still be encrypted and unusable to you.  I don’t know of any recovery places that can crack the encryption.

RoofingGuy wrote:

  I don’t know of any recovery places that can crack the encryption.

So if I did find software that recovered it, are you saying it would be encrypted? Or only if it were done professionally.

Well, I was a tad presumptuous.  I was assuming your My Book is password-capable.  If that’s the case, then the data on the drive are encrypted, and the controller handles the decryption seamlessly, whether you’ve set a password or not.  So, in that case, if a recovery company was to disassemble the drive to retrieve data from it, they’d only be recovering the encrypted data, not the unencrypted form.  If they didn’t have to disassemble the disk, and could access through the controller with whatever software they chose, then they would be recovering the unencrypted data.

So, if you’re accessing the drive through its controller, then things like the software you’ve already tried, or TestDisk, will have the decryption done for them (presuming the controller is working), just as well as with another recovery company.  TestDisk would be attempting to restore the damaged partition table just the same as if the drive were not encrypted, since it’s going through the on-board controller.

If the board is damaged a data recovery service may possibly be able to reconstrusct the board depending on what is damaged on it. About the only person who has a real understanding of these boards is fzabkar. You might try sending him a PM. The data recovery types are pretty secretive about some of their practices and don’t share much with the public.

Joe