Windows 7 network share


#1

I have Windows 7 Ultimate 64 bit,  When I trying get access through network shares I get the “invalid user name or password message” although I do type in the correct name and password. What is the point of that anyway if I can get access through the media servers menu without a password. Actually, what is the difference? Between media servers and network shares that is

I can get thru on media servers but can not see the ISO files?


#2

A password is required because wihtout one anyone on the network can access the files.

Make sure your username and password is all lower case and contains no special characters like &$#(

A media server reads the file and sometimes transcode it  and send it as a stream of data for immediate playback. Shares send an exact copy of the file to be assembled on the other end for storage.

Media servers do not require a password because their entire purpose is to broadcast media to the network not just share it in private. The content for a media server is limited so things like text files cannot be shared which adds to the security.


#3

Hi,

      I bought  a WD HD Live TV this week and had issues with the share too. Last night I fixed it. Turns out it didn’t like the user name I was trying to connect with. I had my first name and last name with a space in between.

I enabled the administrator user in windows 7 and changed the password. I then right clicked the drive I was trying to share and selected the share with. Select advanced sharing and then permissions and added the administrator user to the share and tick all the boxes to allow this user access.

If you have a firewall then there maybe other issues with the firewall so switch it of while testing the above. At this time I have it working but only with Eset firewall on the windows 7 pc off, so still some firewall work to do but that should be easy enough.

Just wanted people out there to know it does work before returning it.


#4

I followed the suggested steps in your  comments and I just can’t see the network shares.

I used to see all the network shares before upgrading to latest firmware.

I tried all combination of passowrd but WDTV always came back with invalid username / password even with a username withtout password.

There must be a problem because I do not put any access password on the shares.

I can see al the shares from another PC on my LAN but not from WDTV.

Do you have any ideas ?


#5

LIve uses linux version of samba for file sharing . sometimes what can happen is any username /password sent from the pc will get converted on the other end to all lower case. So pick something really simple for the username like  mypc  , and something simple for the password like  mypass   and see if it works.

If it doesn’t make sure that your pc workgroups are named WORKGROUP. That is the defualt for the Live and the only place it will look.


#6

The other option, which is a snap, is to turn OFF PASSWORD PROTECTED SHARING.

Yes, this means all shares are now freely available, but it won’t even ask you for a user/password if you do this.