Windows 7 does not recognise my hard drive

I bought a new external hard drive 2TB with usb2 and usb3. Windows 7 will not recognise it.

I can tell the drive is not damaged because my media player recognises it on my tv with no issues.

I have a 3 month old pc.

My usb3 ports in bios are enabled.

I installed the WD SES DRIVER no conflicts in device manager…

Drive does not appear under disk management.

Updated smart ware to the latest version and also updated windows 7 to the latest version.

How do I solve this

I have tried everything and no one can sort this out.

Wont be buying western digital again.

What do you do if you cant see the drive in disk manager???

Did you try running the firmware update again? Do you have another PC to try the drive on? If it doesn’t show in Disk Management most software won’t work for retrieval or repair. Did you try deleting the driver disconnecting drive rebooting and reconnecting? Find a Linux Live CD download burn to disk and try booting from that and see if you can find drive and data.


Yes i have tired it on an old windows xp machine with no luck.

I disconnected and reboted it several times.

I updated the firmware to the latest version.

The drive registers on my media player, so it works.

I even unplugeed the device and ran in from another power point.

I cant get my money back for this drive.

It worked for about 2 weeks then just no longer works.

If you can’t see the drive in disk management, then either the bridge board (the case) failed, or your os has not install the drivers properly.  Have you tried updating your usb 3.0 drivers?  that’s done through your pc manufacturer.  have you even installed the drivers?  if your media player recognizes it and can play media from it, that’s because it’s accessing the drive from usb 2.0.   so, either the usb 3.0 port has failed, or it doesn’t have the drivers installed.  try connecting the drive to your pc using just usb 2.0 cable and see if that works.

I have tried putting in USB 2 slot as well as USB3.

I am out of ideas, I am just dissapointed because i cant take the drive back because i put on sensitive information on it.

Is there an wd outlet or shop i can take this to to fix it??

i tried this drive on several different computers and several different operating systems.

I have to give up.

I will never touch western digital again!!!

My P.C. is running Windows 7.  I also put a new SATA hard drive in my P.C. recently because the P.C. was telling me the original SATA hard drive was failing and needed to be replaced.  I decided to keep the old hard drive in its original position and add the new drive as a second one.  As originally installed, the P.C. still started from the old hard drive and could not ‘see’ the new drive.

I have looked for ways of changing the software to tell it to read the new hare drive (Boot or Startup menues) but can’t see how to do this.  The only way I have found to get round this is to physically swap the data cables over between the old and new drives.  It seems that the mother board recognises the drive connected into one particular port and not the other.  I don’t know why.  I hope this helps.

I got the same problem with My Passport Essential 

my nintendo wii can read it but there’s no pc that can do it 

always send me a message asks me if I want to format it

I will try to install MAC OS in my pc maybe works

can you resolved the problem?

hey buddy this is not a big issue

windows 7 is showin that windows can not recognize it beacause the drive size is 2 tb right?

the it is to big size for your motheboard.

your motherboard is not able to run with 2tb

you have to give connection to the main usb port.

1 or 2 port of usb on motherboard are directly connected to the powersupply

this port can run your 2tb hdd

ok try it