Windows 7 can't see USB HDD attached to WDTV

Hey guys, new here and have done a ton of forum reading over the last couple of days trying to figure this out but can’t seem to find a solution.

Long story short, I bought a WDTV live streaming a few weeks ago, set it up at home (Windows 8.1 on my laptop) and it worked great, can see the USB HDD as a network drive, can manage files easily… LOVE it.

My sister went and bought one on my recommendation and I set it up for her, the USB HDD (WD MyBook 3Tb) that is attached to the WDTV can be seen by the WDTV and movies play off of it.  But with her Windows 7 laptop I am unable to see the HDD, I can see the WDTV on the network but can’t access the HDD.

I have tried the network shares setup that seems to be everywhere but this is the opposite problem.  I don’t want the movies to be streamed off of the laptop to the WDTV. 

attaching the HDD to the computer is not really an option (laptop),  and my brother in law is not the sharpest knife in the drawer so if I can set it up to be ■■■■■ proof so that he can use it easily it would be that much better.

Any tips or suggestions would be greatly appreciated.

Thanks in advance

Not sure if it’s the same, but my wdtv live hub (internal HDD) has a drive for Windows 7 that  you can download that maps the drive to your Windows 7. It’s “wd link”

Try the " WD Discovery Software". It finds WD network products and helps you map drives to them.

From the webpage - “The Discovery Tool is used to locate WD drives on the network, and to create mapped network drives from their share folders.”

You can download it here

Good Luck


Pearl,  i had already tried the “discovery tool” and it does the same thing.  Sees the WDTV but not the HDD.

i will try to see if the link software will do it for me.

Okay, you can grab a copy of the WD Link Software at the link below. 

WD Link Software Download

Hopefully you have better luck with it. Install is very quick and you will know in just a few minutes if it solves you issue.


well i finally made it back to my sisters place and tried the link software.  same thing.  i can see the WDTV but not the drive.   could it be the fact that its the 3TB drive (seem to have read that somewhere) that is causing issues…

im thinking just getting her to buy a new router with USB3 for NAS is going to be the easiest solution… unless anyone else has any ideas.


I also have a WD Live SMP with a WD Mybook 3TB attached.  I can access the MyBook drive just fine from my Windows 7 laptop and my (old) Windows XP desktop. 

Make sure that you have set the Workgroup name in the WD SMP the same as the workgroup name you set on your computer(s) and other devices on your network.  Also, go into Network setup and ensure that “Network Share Server” is set to “On.”  If you change these settings, you MAY need to restart the WD SMP for the change to take effect.  Then, on the Windows 7 computer, open the Network viewer (Start / Network).  The WD SMP should show up under the “Computer” section.  Double-click it, and you should be able to browse the attached USB drive.  You can also right-click that icon, and create a shortcut to the drive; or after double-clicking, right-click the resulting icon and map a network drive.

You may notice that the WD SMP also shows in the Network viewer under the “Media Devices” section.  Opening this only accesses the WD SMP’s web page, NOT the attached drive.