Windows 7 can't access My Passport 1 TB external disk

I did follow most of the posted solution and none of them did work for me. 

Product name - My Passport Essential

S/N -[Edited]

Proudct ID - 0730

Firmeware Revision - 1008

OS - Microsoft Windows 7 Professional

I tried to update the firmware and it is asking me a passowd which I did not have at all. I have not set a password since day one of buying this product. 

I have a lot of critical data on this drive and your help is very much appreciated.

One surprising info is that when I log-in as a gust I can see drive G but can open it. I do not see this when I log in as admin.



You tried or you updated? 

Try connecting to another computer 

Need to be careful when updating since you can endup damaging the drive

that’s the reason why it’s suggested to backup prior to updating



I reinstall Windows 7  and now windows recognize my hard disk but i couldnt access it and doesnt show on my computer. i tried on another laptop and it works. i dont know whats the problem? please help me.



Try updating the WD SES driver for your OS. Worked for me. :slight_smile: