Windows 7 and shared networking, this might help a few people

Not sure if this observation has been made yet but just in case it hasn’t…

I’ve been pulling my hair out trying to get shared networking working on my WD Live and Windows 7 machine. The media server part worked fine right off the bat but I had a **bleep** of a time getting the shared folder to work so I could play mkv files and such.  Finally figured it out and was able to stream from my shared folder(had to configure my Norton firewall and permissions) but then the next day no-go again. It would seemly work at random, might not work for a week then all of a sudden it would be back. Very frusterating considering I do computer repair for a living.

Finally I figured out that it was Windows 7 causing the issue, some sort of bug I imagine.

Whenever my network map looks like this pic below or says ‘No Discoverable computers’ *or something similar* The WD Live Plus wouldn’t find my computer at all.   Other regular computers in my network could see the shares though.

win7map-bad.jpg

However if the network map looks like the follow pic my WD Live device would work fine with networking.

network-good.jpg

Notice the difference?  I leave my computer on and manually put it into sleep mode at the end of the day so I can just move the mouse in the AM to wake it up. If the computer goes to sleep and is then woken up I’ll get the Network Map with the Unknown device or message saying No Discoverable computers or something along those lines.  

If I reboot my computer or go into ‘Network and sharing Center’ then click ‘Change adapter settings’ then disable my network adapter then re-enable it (right-click on the active adapter to get the menu, disable/enable is the first thing) I get the Network Map without the question make in it and WD Live works everytime. Basically it was only working when the computer rebooted for updates and such.  Finally I made the connection with the network map and how it looks after waking up from sleep and how it looks after a reboot or adapter reset. 

Hi, I’ve had similar problems. I thought it was a problem with Norton firewall, I disabled it and wdtv worked for a while, but after re-enabling the firewall it stopped working again. However, I tried disabling it again and the wdtv worked for a little while but then stopped working again. You say you had to configure Norton firewall, may I ask what changes you made? And do you think Norton firewall is in any way the cause of these problems (in addition to what you found out about the adapter, etc.). Thanks!