Windows 7 & 8 network doesn't see WSMyCloud

I have a 4TB MYCloud device attached to our LAN via a switch, while the device works and is accessable, it does not show under networks as a list in either Windows 7 or Windows 8.

It used to, nothing has changed, so I am at a loss as to how to make it show

any suggestions, is greatly appreciated

DB

Oregon US

Hello, verify if the My Cloud is on the same workgroup as your two computers. Check page 82 for more information. 

http://www.wdc.com/wdproducts/library/UM/ENG/4779-705103.pdf#page=87

KarterJK, this is the My Cloud EX2 subforum. Just wanted to make sure that you have the My Cloud EX2 and not the regular My Cloud. The My Cloud forum is here -> http://community.wd.com/t5/WD-My-Cloud/bd-p/mycloud

When you open the network and sharing center, is your network private or public? If public, change it to private. If private already, check that file sharing and network discovery is on through advanced sharing options, or through services.msc

KarterJK wrote:

I have a 4TB MYCloud device attached to our LAN via a switch, while the device works and is accessable, it does not show under networks as a list in either Windows 7 or Windows 8.

 

It used to, nothing has changed, so I am at a loss as to how to make it show

any suggestions, is greatly appreciated

 

DB

Oregon US

Hi Karter,

This behavior happens on a switch. When you expand network in explorer left pane. , and you do not see it, just click network and it will show up, on the right pane, under Media devices and under storage. This happens on my switch but not on my router. Windows is so dumb. My router can find it and map it but Windows sometimes (not always)  fails to look properly (I am currently looking at it in Windows 7 :slight_smile: ).

You can also check by clicking on the network icon on bottom right hand side and open network and sharing center, then at top right click “see full map” and Windows will correctly find  and map the device including the switch.

HTH

hi my friend

i have my cloud ex4 and its the same thing

i think its some windows network or linux bug ( if te bug comes from the device itself

not a big deal

-restart your computer

-when it appears, open network panel, right click and create shortcut :slight_smile:

if the ip doesnt change this shortcut will allways work fine :slight_smile:

its a stupid bug lets see if its possible to correct