Windows 7 64-Bit Support for My Book Studio II ? Anyone


#1

I have the My Book Studio Edition II - 2 TB Drive Model:  WDH2Q20000.

Will this unit work with Windows 7 Pro 64-Bit edition?  IT is VERY scarry as on the WD site it just says Windows 7 support, but nothing about  64-Bit flavor. 

Or  can it be run in Windows XP emulation mode in Win7?  Or if I update all the firmware/software to the latest and greatest will I get functionality?

Why hasn’t WD support made this support distinction clear as I know I’m not the first to ask??


#2

Hi net1994,

Honestly I do think its compatible, and I have not heard yet of someone claiming it does not work. And based on the compatibility chart, it generalizes, and also, most windows 7 versions are 64-bit.

Just to make sure, before using it, try backing up all your info to another drive if possible.


#3

I just bought a 1 TB My Book Studio that has USB, ESATA and firewire connections.  I used the drive under Windows Vista 64 bit using USB and fireware without any problem, although the transfer rate with firewire was very slow.  The problem was resolved when I applied SP1.  A couple of days ago, I upgraded to 64 bit Windows 7.  At first, Windows 7 did not recognize the drive, but I managed to get it to work.  After that, My Book Studio worked very fast using USB.  However, the drive did not work with firewire connection.  Windows 7 recognized the drive and could read the files on the drive, but it could not write to it.  When I try to copy files to the drive, Windows would start the process but end at an error.  Would a firmware upgrade fit the problem?  Does anyone have the same problem??


#4

Well, I just updated the firmware on My Book to 1034, and it is still the same.  Perhaps, USB is slightly (almost negligible) faster, but firewire is still the same, NOT WORKING.  Does anyone have any idea???


#5

After extensive research, I finally found a post that contains a fix to Windows 7 firewire problem, at least it works for my drive.  The problem is actually caused by the new Windows 7 firewire driver.  The soluttion is to replace the firewire driver with the legacy firewire driver.  Below is the link to the post:

http://social.technet.microsoft.com/Forums/en-US/w7itprohardware/thread/65cb7a25-2a84-4875-aa27-b084537e8da1/

If this solution works for your drive, please reply and specify the model of your drive so that other readers would know what model this solution is good for.


#6

Where did you find the 1035 firmware? I just checked and the latest available in the support downloads section for the Studio II is 1.015. Thanks!