Windows 7 64-Bit: Can't Connect Directly to MWBE (2TB, White Light)


#1

Good day,

I’m going to relay my installation experience with this drive and would very much appreciate some help getting me across the finish line!

Upon setting up the drive according to the quick start guide, I was immediately able to access it from a Windows Vista (32-bit) computer. Transfer speeds weren’t stellar, but I’m willing to blame the wireless connection on the laptop for now, especially when you consider some of the wired speeds I observed (more on that later).

What didn’t work at all, however, is setup on my Windows 7 x64 computer. I was able to right click on the drive in Network and “Install,” but I never got the “Open” option on the right-click context menu like the installation guide advertised (I did get this when installing on Vista 32-bit). Instead, all I can do is open the device’s home page with a browser. The online configuration utilities work fine: I was able to log in, set a static IP, etc. Even after setting a static IP, I was still able to log into the administrative interface and access from Vista, so I know I didn’t do anything wrong there. No problems doing all that, but still no joy connecting via Windows Explorer on Win7. I researched and tried many things for several hours. The supplied WD Discovery application found the drive, but when I try to map a network drive to it, I get an error that “\MyBookWorld” cannot be found. I even went so far as to add an entry in Windows\System32\drivers\etc\hosts that mapped the static IP to “MyBookWorld” but that didn’t work either. I tried accessinvia ethgg via “\MyBookWorld” and “\192.168.0.107” (the assigned static IP), but to no avail.

Here are the things I CAN do: I can ping the drive, I can call up the drive’s web page, and I was even able to set up the FTP server and connect from Windows 7 that way. This is where I observed the very nice transfer speeds up to 530mbps (I’m on gigabit ethernet), so I’m quite excited that once I figure out this direct connection, things will be wonderful.

I’d like to be able to use this drive with an assigned drive letter; otherwise, its utility for me is severely hampered and I may have to consider returning it in favor of something that will play more nicely with Win7 x64.

I currently have a support ticket open with WD on the matter and so far, we have eliminated my home network as a cause; I connected the drive directly to my computer via Ethernet and had identical results.

Firmware is up to date: 01.01.16.

Any ideas?  Thanks in advance!


#2

Update: I forgot that I disabled NetBIOS sometime last year while troubleshooting other issues.  I’m good now. :stuck_out_tongue: