Windows 7 (64-bit) and My Book Live Authentication

On the My Book World forum I found a post that said:

The easiest fix for this is to create an account for each user that matches the Windows login. So, if you login to Windows as “Wedgie” with the password “12345,” create a user named “Wedgie” on the My Book World with the password “12345.” Then, you can go into the folder share permissions and give “Wedgie” full access to your private share and you’ll connect to it every time without having to type in a password. Even with other operating systems (Windows Vista, Windows 7, or Mac OS X), this is ideal because you won’t have to authenticate with the My Book World to connect to your private share.

Will that “automatic authentication” work with private shares on the My Book Live 2TB and Windows 7 (64-bit)?

Thanks, Dave

*IF* that summary is correct, then it should apply to the MBL the same as the MBW…

1 Like

Thanks Tony, thats the big “IF”…  :smiley:

I was wondering if anyone had actually tried it.


Gimme a few minutes…

Yep; it works exactly as you describe.

I created an additional user on my Win7 box, named “test” with password “test”

I created a private share on the My Book Live with the same name and password.

When logged into my NORMAL account on Win7, it wouldn’t let me in.

When logged into the test account, it didn’t even ask for a UID or PW; it let me right in.

I never thought of doing this.   Thanks for the info!  :)

1 Like

Thanks Tony!!!


Nice to know. :smiley:

What if the username in Win 7 is “something.something” MyBook doesn’t allow  such usernames!

I have very big problem with this issue, because of my company policy I can not connect to my home data storage!

please help

You can have a different username and password on the My Book Live.

When you try to access the My Book Live, it won’t log in automatically.

It will prompt you and you can enter the My Book Live user and password and still get on.

It is not so simple.

The folder is shared for reading for everyone, and only admin can store and change files. So when I connect to the folder I can read, but not write.

Additionally with win 7 64 bit I can not map this drive with different credentials (normally computer is in the company domain)

That shouldn’t be a problem.

My laptop is also in a corporate AD domain.  I have no problems mounting my NAS boxes with the correct priveldges.

When I double-click the share, it just asks me to log on.

Is your computer not doing that?

No it logs me as user with read only privileges.

When I try to map drive it gives me only option to connect as domain user?

On a home computer also win 7 64 bit (not in domain) this mapping options functioned, and also it was fine with XP in domain.

Something I read somewhere said that when you first go to a public share and it doesn’t recognize your userid it allows you access as guest or anonymous.

What if you create a private share and go to that first.

Will it let you log on as Admin then?

If so, can you then go to your private share and read/write files.

actually now when I restarted, I have all permissions even there where I should not! Something is definitely wrong. Ok it doesn’t let me to my wife’s account. Probably it transfered some permissions when I was transferring settings from old computer.