Windows 10 Doesn't See MY Cloud in Network

I’ve seen a number of others having this problem. Can’t find anything here while searching. Any ideas?

Did you see the tacked thread at the top of the subforum?

Yes I checked the manual but did not find anything to help with my problem.

The manual? The Compilation of Windows 10 Methods, Steps and Solutions thread isn’t a manual. It contains several methods that potentially workaround the Windows 10/Samba issue that was introduced with the Windows 10 November update. That issue primarily revolves around Windows File Explorer not properly listing the My Cloud under Computer or Network.

Perhaps if you explained in more detail what your problem is others will have a possible solution.

Upgrade from W7 to W10 resulted in WDMYCLOUD disappearing from the Network page. Googled for solution and here and tried all suggested solutions but haven’t found anything that worked. I checked through the Compilation of W10 as you suggested but nothing there helped.

When you say you’ve checked through the Compilation thread did you actually try each one of the methods or options? In particular the step that details how to change the Windows 10 SMB version from SMB2 to SMB1?

If you have a spare router that supports Samba add it to the local network and configure the Samba service on that router to act as the Master Browser.

Never mind. Used Disable SMB2 & SMB3

sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
sc.exe config mrxsmb20 start= disabled

and now my NAS appers in my network.

Good to hear the workaround worked. The Compilation thread includes the steps to reverse that setting if you need too. Hopefully Microsoft will fix this bug in Windows 10 soon as it affects not just the My Cloud but other NAS devices as well.

I have a gen2 6TB that for some reason stopped showing up in the network section of file explorer. After checking I found a few things that I’m not sure why it is happening. First when the system reboots /var/log/samba folder is missing. The smb.conf file and secrets.tdb files are missing. Also the orion.db file in /usr/local/config was missing the entry for Public. It seems that the system_init deletes the Public entry from the orion.db. If Public is missing from orion.db then when smb.conf gets rebuilt during reboot it does not put the Public entry in smb.conf.
If the orion.db file contains the Public entry. Then when smbcom is run it rebuilds the smb.conf file with the correct entries. At this point if you try to start smdb you get errors because /var/log/samba is missing. But if you run smb start command everything seems to work. So in short. If after the reboot you enter the following two commands
smb start
It shows up in the network and you can map the drive. My problem is I can’t find where smbcom and smb get started. There are two places that it can happen load_module and But neither of these get called that I can find.
I haven’t done a 40 second reset because I most likely would have made the issue go away without knowing why it is occuring.