Windows 10 does not automatically connect to MyCloud NAS

windows 10 does not automatically connect to MyCloud NAS using Windows 10.
I can reconnect manually via file browser.
There is no admin password, field left blank.

Hello tlfmd,

The My Cloud device can be assessed by logging from the Dashboard or you can login with the mycloud.com website.

SO why won’t it automatically reconnect with a restart and how do I fix that so backups can occur automatically ?

If you use the IP address instead of the DNS name for the unit, after configuring it for a static IP (Or having a reserved DHCP assignment), it should work with auto-reconnect at logon.

Have you mapped the Share? When mapping a Share there is an option to have Windows reconnect at login.

https://support-en.wd.com/app/answers/detail/a_id/25436

Make sure to check “Reconnect at sign-in”.

It IS on automatic reconnect on sign in

I suspect that the mapping is via a share name, rather than an IP. Win10 needs to have SMB1 features enabled to properly find the MyCloud by name, which is not enabled by default. I would set the share up by going straight at the IP.

Is SMB1 (as Wierd_w mentions) enabled? In recent updates/versions of Windrows 10 Microsoft disables SMB1.

How to Enable SMB 1.0/CIFS File Sharing Support on Windows 10

Done, will report on future events

and, I mapped it via IP, not by name

This is kind of a dumb thing to ask, but—

Is the IP address being requested really the IP of the device? (this is one of those “is it turned on?” questions, but still important to ask.)

It IS the IP address the network discovery told me

I will confirm what others have said:

Check that SMB1 is enabled. (do a quick google).
By default, any major update of Win10 will disable this feature. (we could have a longer discussion about SMB).

By habit: I don’t map a drive letter to my NAS. I figure it would make it harder for any kind of ransome ware to find the NAS. I generally type the NAS name into the address bar of file explorer; and usually* I can find it under the “network” section of the File Explorer navigation pane if I don’t feel like typing.

Isn’t it time that insecure SMB1 was retired within WD products completely and SMB2 or higher connectivity was used?

As I’m guessing that’s where the problem is exactly, i.e. WDMYCLOUD is not explicitly visible under network devices, and mapped drives are sometimes shown as disconnected upon restart. Unless insecure SMB1 is re-enabled…

WD has a Support Knowledgebase Article covering the SMB1 issue and the My Clouds.

How to Enable SMB 1.0/CIFS File Sharing Support on Windows 10
https://support-en.wd.com/app/answers/detail/a_id/4155

One can try and edit the firmware to support SMB2 or SMB3.

See Windows 10 Specific Method 6 in that link which explains (at least on a first gen v4.x My Cloud) how to edit the “smb-global.conf” file to set or change the “max protocol” setting.

Thanks - that helpful - it kind-of escaped me that I may be able to elevate SMB version within MyCloud config. I was okay with the status qua as I know how to reach shares etc. directly / manually.

I will try this change today in the evening and report back her with the results.

If that works across the whole range, any particular reason why SMB2 has not been enabled (forced) as a default setting with the latest firmware upgrades?

OK, so am getting confused.

Within smb-global.conf there is already set:

max protocol = SMB3

And Get-SmbConnection reports this:

WDMYCLOUD [REMOVED] 3.1.1

And yet WDMYCLOUD is not visible in Explorer on Windows 10 PC (SMB1 disabled), but it is visible on Windows 8.1 laptop (SMB1 most likely enabled).

So am I missing something obvious?

Or is it rather that only SMB1 will allow seeing it within Windows Networks devices?

With respect to SMB setting, the single bay My Cloud models like to have SMB1 enabled on Windows in order to be seen in Windows File Explorer. If I remember right someone pointed out that because of the old Linux modules used by these single bay units certain newer networking options may not be fully supported (like SMB2 or SMB3) even though one can force the use of SMB2 or SMB3 in the My Cloud firmware.

So one has a choice. Either enable SMB1 on Windows and accept it’s a potential security risk (and lock down the rest of the local network) or disable SMB1 on Windows and use the IP address for the My Cloud to access the My Cloud.

The other setting one needs to ensure is set properly on Windows is the Network Profile. It should be set to Private and not Public on the local network.