Windows 10 does not accept MBL user password

I have moved to another country, which required a new router. I have connected my MBL to the router via an ethernet cable just like I used to in my previous home. I have assigned a static IP address. It shows up as a storage device in file explorer>Network. I can access the UI/Dashboard via a browser using the IP address.

I have access to the files via my phone app (IOS)

When I am trying to map any of the shares on my two Windows 10 laptops, it prompts for a password - three times in a row. None of the user-password combinations defined (admin or other) work. I always get back the same error message “You do not have permission to access \\Public. Contact your network administrator to request access.”

I have tried using the old WD software to no avail. Any hints?

I have exactly the same problem. WD drive has worked for years, I’ve not changed anything, all our iOS devices still access the drive fine, but my Win 10 laptop now refuses to connect. Can access the Drive via IP from the PC, but try to access or remap a network drive and get multiple user / passwords requests. Have tried changing MBL user passwords to no avail. Seems like a Win 10 issue, tried reverting to local account but still no joy

Sounds like an SMB1 issue. Have you installed SMB into Windows? The new default is to NOT use SMB1 as it’s a security risk.

Open Control Panel>Programs and Features

Observe the picture I provide, it’s worth 1000 words :slight_smile:

Awesome - this worked! I had to restart the MBL as well as the laptop but all good now.

Thank you !

Love success stories! Glad that’s all it was! :+1: