Windows 10 can't see My Cloud workaround

#1

I just got an update for Windows 10 and lucky me I can no longer see My Cloud or My Cloud Mirror under Network/Computer in File Explorer. Yay Microsoft! They both still show up under Storage but that just launches the Dashboard. I tried most of the proposed solutions of AllowInsercureGuest, IPV4 use netbios, public-private network, allow network discovery, blah blah blah. Nothing worked.

Luckily I could still get to the boxes typing the UNC name in File Explorer. However every time I closed File explorer it was gone again. If you can get to your MC by typing \MyCloudName\ in the file explorer address bar do this:

Open File Explorer
In the address bar type ‘\MyCloud’ [enter]
(obviously use the name of your cloud including spaces)
When your My Cloud shows up in the left pane under Network right click on it
Select ‘Pin to Quick access’
Curse Microsoft and swear about how stupid it is you had to do this

Your MC should now show up under Quick Access in File Explorer and in my case it survives a reboot. Not sure what issues you may have with third party apps if you want to get to your MC but it seems to work OK. Hopefully MS will come up with a fix that doesn’t require us to force MC to use SMB1.

MyCloud verschwunden
#2

Are you able to provide an image of what you were or are getting when opening file explorer? Here is what I get, see image below and I have the latest Windows 10 update as far as I know, Windows 10 Version 1511 OS Build 10586.36 on both my desktop and laptop.

Click, tap, or activate image to enlarge it.

cat0w
USA

#3

[quote=“NunyaBiznas, post:1, topic:142986, full:true”]
I just got an update for Windows 10 and lucky me I can no longer see My Cloud or My Cloud Mirror under Network/Computer in File Explorer. [/quote]
FYI, several workarounds for Windows 10 not seeing or accessing the My Cloud are discussed in the following thread:

https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576

#4

I tried all of them. No joy.

#5

Windows networking is a complex subject, and the functionality changes with every windows version. :rage:

Also, Windows will only display two things on a network using Windows Explorer; responders (computers) and shares - and only if you have Network Discovery set to YES. Since the WD My Cloud is not a computer you should only see the WD My Cloud under Media Devices (if Twonky is running) and Storage when you click on Network in Windows Explorer.

Nevertheless, there are a couple things you might try to see if you can get yours to be discovered and displayed in Windows Explorer. First, it appears that having a Homegroup in Windows 10 causes issues with Network Discovery from some of the problem logs I have been reading. Also, you must not have your local network declared as ‘public’. It must be Home or Work. and you must ensure that you have Network Discovery ON.

Paul

#6

Did you try, as that link mentions, using an IP address to reach the My Cloud? If so you can map the my cloud via it’s IP address and it can be access each time one opens Windows File Explorer.

Typically and generally with Windows 10, it comes down to either NetBIOS not being enabled over TCP/IP, the network connection is set to “Public” rather than “Private”. Which is a problem I’ve seen with several Windows 10 Upgrades, for some reason Windows defaulted those PC’s to “Public” post upgrade. Once the network is set to “Private” one has to ensure “Network Discovery and File Sharing” is enabled for that “Private” network.

If one is using third party firewall software its possible that firewall software is blocking access.

On my Windows 10 test bed I always have to hit the Windows File Explorer “refresh” button to have the interface rescan the network and then it shows/discovers the My Cloud.

#7

That’s strange. My system always starts from BOOT with my mapped connections them fully connected (no red X) and functional. Windows 10!!? Just full of surprises.

Paul

#8

cat0w
USA

#9

It should have read ‘since the WDMyCloud is not a Windows computer’. My bad.

Paul

#10

Oh I have several Shares mapped, its just the icon for the My Cloud doesn’t show up under the Computer section in Windows File Explorer under Windows 10 some times. When it happens I have to hit the refresh button in File Explorer to have the My Cloud icon show up in the Computer section. For some reason the My Cloud icon shows up under Media Devices and Storage, just not Computer. Its a somewhat annoying quirk with Windows 10 but since I have the most used Share mapped its not normally a problem.

#11

MAPPED drives are, in my opinion, a required function. Especially considering the fragility (?) of the network discovery functions of Windows 10.

I have been researching this for the past few weeks and although I haven’t had a ‘eureka’ event yet, I did discover something that could be useful; Windows 10 will ‘adjust’ both the network share and the firewall settings when minor changes are made to the network environment. In my case this have become a morning ritual for me; changing the firewall settings back to OFF when I discover I have no internet! Because my house here is in a remote segment of my full network (linked by a 2.4Ghz wireless link about 0.5 Km apart), I am unable to have DHCP passthrough work when Windows 10 has ‘adjusted’ the firewall settings. #&%#% <bad words

Ya gotta love Microsoft - it keeps me active as a systems engineer long after I retired from the profession.

Paul

#12

Re: NAS devices do not show under the Network heading in Windows Explorer

I have exhausted just about every technical trick that I could locate on the Microsoft web site(s). Bottom line: there is a bug in the latest update of Windows 10 (Nov. update) that prevents any NAS device from being discovered regardless of what you do. I can confirm this after I damaged my main Windows 10 system several times and had to restore it. Nothing worked.

Until a fix is released you cannot ‘see’ NAS devices on a Windows 10 network using Windows Explorer under the current release of Win 10. You can still MAP those shares, however and that mitigates the failure somewhat. If someone here has an answer to this I’d love to have the details.

Paul

#13

Are you saying that NAS systems don’t show up under the network tab on the left side of windows explorer?

My laptop is in windows 10 with the latest update. I can see all of the NAS devices on my network. Plus any other PC on the network.

RAC

#14

My system is a desktop (ASUS ROG) on the latest build of Windows 10 (Version 1511 Build 10586.29). If you are on the same build, I’d appreciate it if you could list the non-Windows ‘service’ programs that you have installed please? For example, Virus checker, Malware blocker etc. Also, can you verify that you have Windows Firewall turned OFF for both private and public networks?

From my reading over the past few days they are saying this problem exists in all implementations of this version.

Maybe not! :scream:

Paul

As you can see from my Windows Explorer, the cloud is there as storage and as a media device but not as a network client (computer). Part of the problem may be the Samba services in Windows 10. Someone suggested changing the services and I followed their suggestion; It didn’t work and a Windows reload followed! LOL

#15

OS Build 10586.36

Here is my File Explorer view. When on Network MC only shows up as Storage which launches the dashboard. Wonderful how after 50 years the MS Engineers decided to change the name of the default workgroup to ‘Homegroup’.

#16

Win 10 Pro version 1511 OS build 10586.36 does the same. Doesn’t list the My Cloud under Computers.

#17

Homegroup is not the “network” or “workgroup” name. On my Win 10 PC if I go to System Properties the “Workgroup” entry still shows “WORKGROUP”.

The following Microsoft link explains the difference (at least under Windows 7) between; domain, workgroup and homegroup.

What is the difference between a domain, a workgroup, and a homegroup?

#18

This is my desktop system. I see that AbbottandCostello is missing from storage. I’ll have to look into that.

RAC

#19

Is AbbotandCostello your WD MyCloud? And what build is your Windows 10? This is strange.

But, hey, we’re talking about Windows here - 100,000,000 lines of code to accomplish what 1,000,000 can do. :laughing:

Paul

#20

I have a slightly different twist on this. I use Paragon Hard Disk Manager 15 Suite and have been for some time. Either caused by the last major W10 update, I just updated to the current build of HDM15S which no longer sees my WD MyCloud. I have submitted a trouble ticket to them on this.

No problem in Windows though and no trouble at all in W7!