Windows 10 Cannot access My Book Live with File Browser


#26

This is interesting. This seems to indicate this is a issue with Windows and not the NAS. Makes sense because as mentioned before the Firmware of a the twin drive MBL is more or less the same as the single drive MBL.

After I’ve survived the new new year. I put a short-cut to this thread on my computer so won’t forget.


#27

Hi Myron. I hope you survived the New Year :grinning:
You have a chance to look at this problem yet?


#28

It seems, that in Windows 10 /1511 the server message block (SMB) protocol version 3.11 is the standard. In Linux this protocol is supported beginning with Samba version 4.2. Most of NAS, routers etc. run under Linux, but in earlier versions.

I found in Microsoft Support the following information to disable the versions 2 and 3 of the SMB, link:

How to enable and disable SMBv1, SMBv2, and SMBv3 in Windows

To disable SMBv2 and SMBv3 on the SMB client, run the following
commands:

sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
sc.exe config mrxsmb20 start= disabled

To enable SMBv2 and SMBv3 on the SMB client again, run the following commands:

sc.exe config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi
sc.exe config mrxsmb20 start= auto

Run cmd.exe as administrator and insert (now in Windows 10 also with Ctrl+v like in any other application!..) the 2 commands to disable SMBv2 and SMBv3.

After a new start of windows, I could see my MyBookLive again:

To reset the suppressed protocols, see the commands above.


#29

Hello all,

I was having the same issue with my MyBookLive’s (I have 2 right now and 1 MyCloud) or so it appears. they would only let me open them to a browser, even right-click ‘open’ didn’t help.

I was able to get into my other network toy, a MyCloud, without issue. I went into the 2 other MyBookLives and added a username that matched my Windows login and password, which were not required before. It still didn’t help until I rebooted both of the boxes.

Now they show up at the top in the area where PC’s with shared drives did and i can open and browse as i could before.

I hope this helps some of you. the other solutions seemed way too complicated for me, even though I’m a IT guy, I still look for the easiest solution. I think if you want the boxes to behave like they did with Windows7, use the “Paul_Rohrer” above. I’m lazy, so I’ll not do that unless i have to.


#30

Thanks all.
Duncan’s solution seems to have worked.
Interestingly, myBookLive shows up under Network in Windows File Explorer.


#31

I’m having a similar problem. I have recently upgraded from Windows 7 to Windows 10, and I cannot see my networked MyBookLive under “Network” in File Explorer, though I can see the Public part of MyBookLive under “This PC”. Curiously I also upgraded a laptop and I cannot now see MyBookLive in either place, though I am certain that for at least a time after the upgrade I could see and access MyBookLive under “Network”, though it has now disappeared.


#32

As the one who started this thread, I have been watching it closely hoping for some resolution that would encourage me to have another go at upgrading to Win10 with good confidence that I will not be facing the same issue. Clearly from the responses that have come in, others are having the same or similar issues. Some have solved it by workarounds or hacks, which to my mind should not be necessary. So where do we go from here? Is this a matter that needs to be addressed with Microsoft via their support forum, or with Western Digital? Otherwise, it just seems to be going around in circles.


#33

I would like to add a further (strange) observation. Yesterday, without my having done anything, MyBookLive suddenly “appeared” under “Networks” in the Navigation Bar of File Explorer. However, after a reboot it disappeared, and is no longer there. When it was there it also appeared twice in in the right hand pane, once under “Storage” (as before) but also under “Computers”. At the same time as MyBookLive appeared in the Navigation Bar, some other components also appeared (such as my HomeHub router) and were also added to the “Computers” section in the right hand pane. These other components have now gone too. I will attach a screen grab (if I can!) for when MyBookLive was displayed.


#34

This is how far I’ve got trying to raise the issue with Microsoft:

http://answers.microsoft.com/en-us/windows/forum/windows_10-networking/cannot-access-western-digital-nas-with-file/f4eb4c02-31ea-473d-8cd7-5b5c597d533e

Ridiculous state affairs.


#35

Finally got some feedback on the Microsoft TechNet forums:

https://social.technet.microsoft.com/Forums/en-US/bc8a9735-a299-4f08-90e1-3469c67f5b4f/cannot-access-western-digital-nas-with-file-browsers-after-windows-10-upgrade?forum=win10itpronetworking#bc8a9735-a299-4f08-90e1-3469c67f5b4f

Make of it what you will.


#36

Hi All,

I solved the problem by putting a small batch file in my autostart folder:

logon.cmd:``

net use y: /d
net use \ \ 192.168.0.nn\sharename z:\ /y

(remove the spaces at the backslashes)
(so use it to map your fixed ip (not dhcp) and networkshare to a drive letter.


#37

Thanks a lot! I had the same problem, Workstation service was not enabled. No it is fine again.


#38

Do you mean the FB app for iOS devices? Well, try re-sharing the My Book Live with the PC, I have heard of many problems of Win 10 having share issues.

Thanks for reminding me to NEVER move my Win 7 to Win 10. I have a Win 8 I “may” move to 10 someday, but still hearing of issues like yours gives me pause about rushing into it.


#39

Use the Run Command " \MyBookLive" Pops right up.


#40

I have simple solution.
Open Programs and Features
Choose Turn Windows Features on or off
TurnOnOff
Open SMB 1.0/CIFS File Sharing Support
Select SMB 1.0/CIFS client
Click OK
Restart computer.
That is all.

Hong


#41

I had the same issue with My Book Live after migrating to Windows 10…

After searching through the internet, I think I solved the issue (or at least mine).

What I did was to change my WD name to all CAPS (e.g. not ThisWDC, but THISWDC)… yes, it seems weird but Windows 10 windows explorer only recognizes network names in CAPS.

Let me know if it helps


Neither MyBookLive nor WD MyCloud appear in File Explorer listing
#42

Thanks for the reply.

This issue is of very recent onset (last week or so) on a computer on which File Explorer has successfully accessed both MyBookLive and WDMyCloud for well over a year without any issues.

I am starting to wonder if it may have something to do with one of Microsoft’s ubiquitous surprise updates. I remember that a day or so before I noticed the issue, the computer had restarted itself and was awaiting entry of the password. I hadn’t noticed that an update was pending, but I probably missed it.


#43

That fixed my problem! Thanks.


#44

When attempting to map a drive to the WD device as suggested in another post, Windows 10 responded with:
System error 1272 has occurred.

You can’t access this shared folder because your organization’s security policies block unauthenticated guest access. These policies help protect your PC from unsafe or malicious devices on the network.

Googling that (not Bing as it turns out this is a MS initiated bug) discovers that Windows 10 turns off access to “unsecured” devices by default.
https://support.microsoft.com/en-us/help/4046019/guest-access-smb2-disabled-by-default-in-windows-10-server-2016 from Microsoft discusses how to use Group Policy to change the “Enable insecure guest logons” so that you can once again access the WD device.

WTG M$! Unbelievably frustrating that this would be changed and set as a default without any sort of notification, work-around, or notation in release notes. Regardless, hope this helps someone else.


#45

My fix is, use a sftp client to login the driver with root/welc0me, then navigate to the folder you have permission issue, change the properties to all control 777, set to recursively.