Windows 10 can access files from My Cloud but not copy onto USB or desktop

#1

I have had a My Cloud drive for a couple of years now which I access wirelessly on a pc running Windows XP. I had no issues at all until last week when I decided to buy a new Lenovo pc that had Windows 10 installed. I was able to download all the WD software that I had on the last pc and also mapped the drive. I store mostly music and was able to build a new iTunes library transferring the files over (albeit painfully slow). I decided to copy an album from My Cloud to a usb stick but I get a network error message asking to skip, try again or cancel. I guess this is the first time I have tried to take a file from My Cloud and copy it else where as I have created the iTunes library on the My Cloud drive as well.
Can anyone offer advice on what’s wrong and a possible solution

#2

Is the USB stick plugged into the back of the My Cloud? Or is it plugged into your Windows 10 computer?

Are you using Windows File Explorer to copy the file from the My Cloud to the USB stick?

You shouldn’t have any problems copying files to the USB stick provided it is in a format the computer and or My Cloud can read/write too and isn’t some how write protected (locked).

While the following link may not help in your case it contains various steps to try when having problems with Windows 10 and the My Cloud.

https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576

#3

Hi Bennor

Thanks your quick reply. Yes, the USB is plugged into the back of the PC but I have found the solution to the problem by adding My Cloud to the list in credential manager. The solution that worked:

Choose Control Panel
Choose User Accounts then
Credential Manager
Windows Credentials
Add a Windows credential
Enter device name in internet or network address field
Enter username for WD device in Username field
Enter password for WD device in password field

Hope this helps anyone else with the same issue