Win 8.1 Pro - Sharing issues !!

Sorry for the long somewhat detailed post, but I thought it important for everyone to see all the issues.

I don’t claim to be a guru when comes to networks/permission’s and sharing, but I’ve been successfully doing it without any real issues since Win 98.
I thought I would make the leap forward and install 8.1 with all its updates the other day, so far a mistake.
I have always done this with all Windows versions, as soon as the install is complete I change the default directory/location for “My Documents” to and separate data HDD, in this case happens to be my G: drive. Then I share this drive. I only have one user account and it has full administrative rights.

  1. First issue is when I fired up my WD Live media player and could not find or access My Documents. It was trying to look where the old folder was located on my C: drive when 8.1 was first installed. No matter how many times I tried to redirect it would not work. I went in and G:/My Documents was listed as being shared. I messed with a few things under permission’s and low and behold I was able to access the folder.
  2. Ms Office 2010 was installed, and I imported my .pst file and OL wrote the folder to my G: My Doc. I had OL opened a few times and sent mail with NO issues. Today I tried to Open OL and got an error saying I don’t have permission to access the file. I went to the file and it shows its shows that the administrator account I log-in with at startup has Full permissions.
    I tried creating a new user account and giving it full admin rights, was successful up unto the time when I started try to share and add permissions, it basically came back with an error saying “shared items are not accessible when your computer is asleep”. Really, I’m on my desktop yet Win 8.1 thinks its asleep? ? ?
    I’ve never experienced such a nightmare of permission and sharing issue in my life.

I deleted the .pst file of my G:/My Doc, boy did that turn out to be a mistake. What really ticks me of is I have uninstalled Office 2010, deleted everything I can find in the registry and temp folders, but somewhere my OL settings are retained. So when I try to run Outlook it now opens with an error because it can no longer see the data file I was using, and then closes. I just want to do fresh clean install and start from scratch, but Ms had made that impossible. I have run a couple of registry and uninstall cleaner utilities but they are not getting rid of everything Office / Outlook wise. I’m running Win 8.1 Pro

I went that route already of creating a new User account, that is partially how I fixed my sharing issue with my WD Live, but it did nothing to fix my Outlook problem of not being able to access G:/My Docs. At this point I see no way out except to format my drive and do a clean install of Win 8.1 Pro.

Did another clean install of Win 8.1 Pro, and followed the below article. This time around Outlook is working with no issues, but once again I can not connect properly with my WDTV Live. I got it to connect to my Desktop, yet it does not see the Documents folder. Its shared, and permissions are Full. I get the error saying it can not connect to the selected source Please make sure selected source is active and available for sharing. It didn’t work before windows updates or after updates were installed. I put my other SSD back into my PC with Win 7, and with no issues at all, connected and streamed video. Not sure what Ms has done, but I can assure its nothing on my part.

I misified as to why I was finall able to get the WDTV Live to see and access G:/Documents, and now with a fresh install of Win 8.1 Pro and the same network settings I can no longer access my PC. “Unable to connect to selected source. Please make sure selected source is active and available for sharing”. I’ve got to the point that it can see my desktop at times, but does not see My Documents.

I don’t ever share complete drives but only folders so when I installed 8.1 Pro from scratch, I simply added a share to the media folder (rather than “My documents”) on my desktop PC’s 2nd drive for the main user I’m logging in with. Then I logged in from the WDTV over SMB with this user’s credentials and now I can stream all media without any issues.