Win 8.1 app problems

I have a MyBook Live.  It works well over our home wireless network and over the internet with all of our iOS devices.

I recently bought a surface pro 3 and installed the WD app on it.  On first us at home it found my drive but told me that an update was needed.  I applied the update to the drive (installed DLNA in place of twonky media) and the drive was initially recognized.  The app “churned” a bit finding files/folders then stopped and I was left with black “tiles” which were grouped into types (pictures, videos, music).  No images were on the tiles.  I then closed down my Surface.

On restarting the tablet the app now reports that “No supported WD devices” are found.

I have tried

  1. Installing the WD discovery progem.  That works fine
  2. Uninstalling and reinstalling the app (no dice)
  3. Removing and reinstalling the drive through “devices and printers”-- no change

It is quite frustrating (and quite eye opening) that the application is so difficult to use.  It represents yet another checkmark on the “do not keep this device” column.  Why Microsoft (or WD) can’t get this right (and make it simple) is a puzzle to me.

That said, can anyone help me with this?

Thank you.

Are you able to access and map the drive directly? Updating the NAS should bear no effect on the application, so was an additional system or Microsoft update installed on your computer after the last time the application worked correctly?


Having read further about the app, I am wondering whether the problem is that I am trying to connect to the drive over a WiFi network.  Does the app support wireless connections? Will it support connections over the internet as does the iOS app?