(Win 10) My Cloud Device Only Displays Under Network With SMBv1 Turned On?

#1

(Win 10) My Cloud Device Only Displays Under Network With SMBv1 Turned On?

Is this normal behavior? I had SMBv1 disabled and noticed I could not see the product under computers to access the shares direct.

Is there any way around this to get this to display with SMB1 disabled? Or basically has it got to be enabled?

#2

Is this the My Cloud product you have ?

If yes, is it in the same workgroup as your Windows 10 computer? Look at this for more information.

#3

Make sure Windows 10 has all the latest updates. There was an issue with one Microsoft update last year where there was an SMB issue that prevented the My Cloud from being found. See the following discussion for more information.

https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576

#4

Yeah that’s the one.

It automatically picked up the workgroup in the network settings. Does that sound correct?

The PC also has all the latest Windows 10 updates.

#5

Yes, see image below.

Click on, tap or activate image to enlarge it.

My desktop and laptop are both in the workgroup. Both have Windows 10 with all updates.

Network Discovery is also on in the Control Panel.

#6

Yeah that’s all set thank you. Still will only work with SMB1 enabled. If I disable it I can’t see it under networks.

I take it that’s just the way it wants to work?

#7

I finally found what you are asking about on my computer, Windows 10, my desktop. It is on and has always been on, I know I didn’t turn it on. My, My Cloud has always worked properly so I have had no reason to look for this.

#8

Yep that’s it. If that SMB 1 is disabled. You can no longer see the device under network - computer…