Will 'WD My Passport Studio 2tb Mac' Work?

Hi guys, i am interested in buying a WD TV Media Player for the sole reason of playing my movie files on my TV.All i really want is to hook the player to the TV & then connect my external drive to the player.

Before i go out & purchase this item i am trying to find out if my hard drive is supported with WD TV Media Player.I am a bit curious as i cannot find any info on this.

My external drive is a ‘WD My Passport Studio 2tg Mac Format’.

Also i have noticed that the format is ‘os extended (journaled)’. i have read elsewhere that this could be a problem.

Can anybody reading this tell me if my external hard drive will work with WD TV Media Player?

Thanks for your time,


WD My Passport Studio is listed as a compatible device  (check your model number)


Also i have noticed that the format is ‘os extended (journaled)’. i have read elsewhere that this could be a problem

You won’t be able to use the Media Library (Get Content Info, Thumbnails, Movie Info etc)  … if you disable the Media Library, then it should be ok.

The Media Library process failed.

Make sure that:

• the USB device has no read-only protection.

• the USB device is not using the HFS+ file system

with Journaling enabled.

• there is enough storage space on the USB device.

Page: 214   http://www.wdc.com/wdproducts/library/UM/ENG/4779-705123.pdf

1 Like

Thanks for your reply.Unfortunately the model number on my drive does not match the one listed.

Here are my hard drive details:

P/N: WDBS8P0020BBK-00

Most (if not all) Western Digital HDD should be compatible … i have the following, and they all work with the WDTV

  • My Passport Wireless (Works Wireless and USB Connected)
  • My Book (3TB)
  • WD Elements (3TB)
  • WD Elements SE (1TB) x3 (self powered usb)

Edited.Thanks for pointing that out i didn’t even realise sorry.

that’s alright … as per my post above, i’d be very surprised if it did’nt work with the WDTV

Hopefully it should be ok then as i use a WD drive.

Also i have figured out how to disable ‘journaled’ from the hard drive.That should do the business i hope.

Thanks for your help Joey much appreciated.