Will My Book Duo configured in RAID 1 continue to work if one drive fails or only after replacing the failed drive and performing rebuild?


Quick question.

Will My Book Duo configured in RAID 1 continue to work if one drive fails or only after replacing the failed drive and performing rebuild?


With RAID 1 and one drive fails. You should still be able to access your data. After you replaced the failed drive. You can use the WD Disk Utility to rebuild your data to the new drive.


Doesn’t inserting a new replacement disk initiate the NAS to self-start the rebuilding process from the disk with data?

It will work once the failed drive is replaced.

Thanks for the responses.

One of my drives failed. I wan’t sure whether the remaining drive was still accessible through the enclosure as the drive no longer shows up in Computer.

I’ve just replaced the drive and finished rebuild, both drives show as Healthy now but the drive still does not show, any suggestions? Partition damaged?

My Book DUO is an external USB device. It is not a NAS device.

My question was does a NAS auto reinstall a replacement RAID 1 disk when it is inserted?

You can ask that question in the NAS forum. I’m pretty sure you know some about the WD NAS products. You have help answer a lot questions from other in the NAS forum. You should know the answer to your question.

I was asking YOU here, can you answer it?

Hi, thanks again people.

I’m sorry I’m not very knowledgeable about using all the right terminology if it caused any confusion.

This is my experience in the end and how it got resolved, hopefully it will help somebody else who may encounter the same issue.

There was a power outage in my area after which, my My Book Duo 2 TB (drive G:) started blinking red where the power indicator was and also the LED’s for both drives. I no longer saw drive “G:” in my computer either. I tried first plugging it into another PC but the drive did not show up. I then re-plugged it into the original PC and opened WD Utilities, but WD Utilities could not see the drive either. I then took the top cover off and took out Drive 2 which didn’t do anything still, so I plugged it back in and took out Drive 1, and that connected the drive, but still no drive G: yet. Using WD Utilities Drive 2 showed as RAID degraded. I purchased another WD Red 2TB, and plugged it into Drive 1, and used WD Utilities to do the rebuild, which took 8 hours, during which I still didn’t see drive G: come back. After rebuild completed, both drives showed as “healthy”, alas still no drive G:.

I read up a bit online and figured maybe the partition was bad and downloaded a software which found the files. I had to pay to activate this software and thankfully I was able to export the files I needed in the end. I think someone who is more tech-savvy would be able to do this on their own without having to pay for software. Me? I’m just happy to have my files now.

What software did you download?

You had to pay for software? Not all good software is free, ya know, but there is a lot of bad software that is free

I tried EASEUS and it ran a scan and showed the files, so I paid to activate the recovery function.

Fortunately it did bring all the files back.