Will Device Reset clear out the RSS Feed catalog? I hope so. Please advise

Experimenting with RSS feeds, I attempted (via the web interface) to add a folder, and then assign a couple of feeds to the folder. Those two feeds have gone “invisible”. I cannot see them via the web interface, and they don’t show on the TV. The folder was visible but empty on the TV, but for some reason it is also now invisible. Because I can’t see them I dan’t delete them, but if I attempt to add the same feed again the hub says I can’t do that because it already exists.

So, I managed to quickly somehow find a bug in the RSS FEED managemt and corrupt the RSS feed catalog, but I can’t find a way to clear it out or rebuild it. I did a “clear media catalog” & rebuilt, but that didn’t seem to fix anything.

The question is: Will a “device reset” clear out the RSS feed catalog? I thought I’d ask before doing that. Otherwise, the 3.00.28 firmware seems to be working well for me.

I’m glad that I’m not the only one with this issue (not that I’m happy that is happening to you), I did have this issue with few RSS, I did a factory default reset and it work for me… (emphasis on it worked for me!!!)

I did the factory reset, and it cleared up the problem a little bit. I was then able to add the two feeds that were previously “hidden”, but it’s still goofed up. Now on one of them there are two copies of the feed that cannot be deleted. So, the RSS catalog is still mangled.

Question… did you also delete the Western Digital feeds and folder that was in there by default? I did that, and I suspect that’s at the root of the issue. Perhaps when everything is deleted, and the RSS feed list is totally empty it gets confused.

If that’s the case then I may have enough info to input an issue item.

Same here. Created folders and feed to go in them but they disappeared. Doing a factory reset took them out completely and I didn’t try putting the same feeds back, which were from http://www.archive.org . If it makes a difference where they’re from…

I also had deleted the WD feeds.

Ok, I’ve entered an item in the Issue Exchange for this problem. Title begins with “RSS FEED listing”. Y’all might want to visit that and give it a bump up, and/or improve it with additional findings.


This issue never seems to be solved - it is still the same problem in fw 3.04.17.

So if you have this problem pls. visit  http://community.wdc.com/t5/WD-TV-Live-Hub-Issue-Reporting/RSS-FEED-listing-quot-catalog-quot-becomes-corrupted-and/idi-p/313406 and give it some kudos so it can get some attention by WD.