Wierd Router Dependency

  1. I have a 3Tb MyCloud unit attached until now to a TP-Link router. Every thing is fine. I have upgraded my phone line from 15Mbps to 40 Mbps, requiring the use of a VDSL modem/router. I chose a D-Link DSL-6740U unit. It works fine with everything except the MyCloud unit, which fails to acquire an IP address from the new VDSL router. Just to be certain that it was then new router misbehaving, I daisy-chained D-Link router to old TP-Link unit through latter’s WAN port, and attached my workstation and the MyCloud unit to the TP-Link router. Everything now works like a charm. 2. I should like to hear from anyone who has experienced a similar problem. 3. I have cross-posted this query to D-Link Technical Support

Have you tried restarting the nas? Or quicker from ssh “service networking restart”. You could probably set static ip too.


  1. In moving the NAS from TP-Link to the D-Link, I reset the NAS to factory defaults so that it could connect to the D-Link via DHCP. Previously it was set to a fixed IP on the TP-Link on a different subnet.

  2. To set a static IP  I would need to -

a. Reserve an IP on the D-Link (easy)

b. While connected through TP-Link , change to a fixed IP address and subnet mask for the D-Link. I should immediately  loose connectivity to the NAS

c. Connect the NAS to the D-Link, and with luck it should be recognized

That leaves open the $64,000 question: How would one do this without a spare router???

By the way, I received a reply from D-Link in the US: They don’t support my unit there. I have to post my query to D-Link a region which supports it! Well, this DSL unit is made in Russia - and I don’t speak a word of Russian. Wonderful!


If you have reset to factory defaults, then the nas should now accepts dhcp. Please reconfirm this from the wd dashboard while connected to the old router. Or you could just do the 4secs reset to revert the static IP (power on while holding the rear reset button for 4secs).

Just to add that your point#2a-c should work if your old nas static IP is something like and the new router mask is subnet 192.168.0/24 mask

OK. It looks like I had D-Link issue, which I won’t go into further (unless someone is particularly interested). All works now.