Wi-fi worked, updated firmware, now isn't recognized

-Live Plus

-Belkin N300 (I have since seen that this isn’t on the official list of approved chipsets, but it workED at first…now it doesn’t, so I know it has to be able to work again)

Out of the box, everything worked great.  I skipped updating the FM for weeks, no reason, just because.  Finally, I got sick of it saying “New Firmware…” so I did the update.

Ever since, wi-fi doesn’t work.  No blinking lights on the dongle, and my externals take FOREVER to get read/recognized.  Before, they would load in seconds…now I can sit for up to 5 minutes before it even lets me navigate any menus.

Wishing I had just left it alone and used it with the “old” stuff, as at least if actually worked.  Now all I want to do is throw it out the window.

-did rollbacks (the B’s, not V’s…as it is a Plus)

-did factory resets

None of the rollbacks resolved anything, nor did factory resets…of which I did many.

Any ideas?  Thanks in advance.

Ouch men, unfortunately, because is not in the supported list, it is a bit tricky, the device might work, but it can stop, without any warning…