Why wont my folders show up when I click on network?

The thing is weird. I click on network and i see wd cloud storage then when i double click it … it takes me in my webrowser to the wd cpane page. I dont want that I want to transfer my files to the folders. I can find the darn folders.

What computer are you using? On my Windows 10 PC’s I just click on file explorer>Network>WDMyCloud and all my shares open then I can open files in the one I want. See example image below. Click, tap or activate image to enlarge it.


Mycloudmirror was working fine, despite numerous issues starting up. Then turned off computer. Turned back on.
Unit not on network, Doesn’t appear on router, and nothing appears on the system. Running Windows 10.
Does anyone have a clue?

Windows 10 is well known to have problems showing the My Cloud in the network neighborhood. There are numerous threads on it, if one searches this subforum.

Start by taking a look at the following thread/link that has some general methods that have worked for some.


windows 10. it just showed up after i diconnected everything and connected everything back

I have several WD drives linked to my network, including a WDMyCloud. All have been working fine until recently. I can no longer access my folders on the WDMyCloud. The drive shows in the left pane of my Win10 PC, but clicking on it gives me " it is not accessible you might not have permission to use this network…The remote procedure call failed and did not execute" message. If I open the dashboard and Users or Shares tab, admin as user is there & checked but under shares access, all the options are grayed out. To my knowledge I’ve made no changes to anything. All the other drives work as before. I have all of my music files stored on this drive, how can I get it to allow accessing the folder again?
Strangely, I can still play the music tracks from the share using Kodi on my network connected HTPC. But I am not able to see, open and add any files to it. Did a system reset hoping if I reconfigured it, that might fix it, but again all the shares access options are greyed.

Windows 10 auto-update is mandatory, as I understand it; one of the common complaints. So, whilst you may not have made any changes, Windows may have…

Have you checked the link Bennor’s posted a couple of posts up?

I’m getting real close to abandoning Windows 10 altogether after this insane battle with it to just keep my network drives up & available. I’ve shut down & unplugged everything, reconnected, roll back to earlier restore points, rebuilt win sockets,restored TCP/IP, edited the registry …literally nothing is working.
Now, none of the 4 WD drives I have are showing in the left windows explorer pane under Network at all. When I click on the Network icon, they appear on the right, but all I am able to do is right click on some of them & create public share (the 2 MyClouds, but not my main MyBookLiveDuo, for that nothing happens) I can access the drives webpages, all of them show the admins share access is greyed out. I’d been looking forward to a relaxing long weekend listening & viewing my Media Library, instead now I’m playing Network Detective. I’ve NEVER had these issues with Win7 - it.just.worked.
Drives>GBitswitch>Archer C7 router>PC

What I’ve done on the one Windows 10 machine that is having trouble (SMB related) with the My Cloud is to “map” the Shares in Windows 10. See this WD Support link or the WD My Cloud User Manual for more information on how to “map” a share/drive. I have no problems accessing the “mapped” networked share on the My Cloud this way even though the entire My Cloud drive fails to be listed under Computer in Windows File Explorer. There are various SMB workarounds that are mentioned in the Compilation of Windows 10 Methods link above that I tried which work to solve the problem(s), but reverted this Windows 10 machine back to stock since I use it as a test bed.

Well, strange things…using WD QuickView, I selected each drives dashboard, went in & rebooted each drive (for some reason I’m unable to get the dashboard for the MyBookLive to open, the link in browser shows the IP\ui, but it is a blank page), and lo & behold…drives are back & accessible again! However , since I did a restore point from back on 12/18, I’m wondering how long it will be until Microsoft’s mandatory updates will mess it up again. If and when this happens, back to Win7 I go, life’s too short. Many thanks for all the helpful responses here - much appreciated & Happy New Year.

HAH…well that sure didn’t last very long. Had everything working again, Kodi could see the drives I could access them in Win Explorer to add files, etc. Just happened to check again just now…drives are once again missing under Network icon in left panel. Nothing to click on to map the shares if I can’t see them…:rage:

Went back into WD Quickview, where I’m able to map them from there. We’ll see how long it lasts.