Why, why did I upgrade to OS5

I resent one of my users the invitation for cloud access but when they click the link they get an error “Request Rejected, the device owner rejected your request”.
I did not. I never even received a request to approve or reject.

So before deleting this account and re-create I set up a test account for myself (different email), sent an invitation, clicked on Create Account, created the account and then tried to login, only to receive an error that the device is not supported.

What in the world is going on??

2 Likes

@sbi, please send us the My cloud logs and screenshot from the error thru private message.

Hi there, I am having a similar error.

I send the invitation to myself from the cloud, I click on the email link, log into os5.my cloud.com and receive the “Request Rejected” The device owner rejected your request.

Very frustrating and disappointing.
Please help.

I am having the very same problem. User gets rejected almost instantaneously - I get no request to confirm the access. As I invited the User why do I have to confirm?

@ant_s
Have you already contacted support and attached your system logs?
If so, what are your case numbers?
If not, please collect the systems logs and sent to support.

Device is a MyCloudMirror for which support has ended i.e.:
Support for this product has ended and is no longer available per [WD Product Software Support Status]
For assistance Ask the WD Community or reference the online Knowledge Base.

Hi, I have exactly the same problem. Upgraded my EX2 Ultra to OS5 (V5.11.112). After I sent my users an invitation for cloud access they immediately get the “Request Rejected, the device owner rejected your request”. response. Before with OS3 all went fine. I created incident 210325-000171 at WD Support but don’t see an option there to attach the system log. Anyone know a solution to this? Many thanks!

Delete the user account and recreate it, then send the invite again. OS 5 in most cases is a complete downgrade from OS 3. Boggles my mind why this was even considered to be released, wish I could roll back easily the developers should be fired over the complete uselessness of the file storage and organization when compared to OS 3

1 Like

I have the same “Request Rejected, the device owner rejected your request” issue with a MyCloud EX2 Ultra and the OS5 MyCloud web interface for remotely accessing the Acronnis TrueImage backup. My question is how do I delete the user account in order to recreate it with a new invite?