Why was the thread about inacessibility locked?


#1

Considering that it saved my bacon and I now have an uptime of over two weeks I’m very glad it was there with the solution.

But I really do think that WD (LOVE their hard drives BTW) should have come up with an official patch to rectify the situation, rather than rely on hard-to-find word of mouth.

Why NOT?   Their techs can’t be unaware of the problem?

Can we not have the courtesy of a comment WD?

Thanks

The Cutter


#2

Would you mind linking to the solution you found? Thanks! :slight_smile:


#3

Can’t find the O/P from “Vlado” but I quote it.

***************************************************

"Here is an update guide from dzentai how to fix this problem till we are waiting 9 months for new firmware which should fix this BUG permanently.

In the web configuration switch to Advanced Mode, then on the System tab using the Advanced button check the SSH Access checkbox on the top of the page, then Submit.

Using Putty or any other SSH client connect to your NAS’s IP address, and log in using “root” as username, and “welc0me” as password!

Now you are inside your NAS.

Type the following on the prompt (this will move/save the startup scripts to the /root/ folder and disable running of mionet and twonky main program and miocrawler it is unnecessary):

mv /etc/init.d/S9M_mionet /root/

mv /etc/init.d/S97twonkyserver /root/

mv /usr/mionet/bin/cvm /root/

mv /usr/mionet/changeNotifySocket /root/

mv /usr/mionet/plugin/miocrawler/miocrawler /root/

then reboot your NAS with

reboot

 
Disable all other unused services in the web configuration to free up some more RAM and make your NAS more stable.

 

Or something for experts.

 

The white light has an option on the web interface (Basic > Remote Access) that allows you to disable Mionet at startup, unfortunately, while the startup script correctly obeys that setting, there is a bug in a watchdog script that ignores it and will re-enable Mionet every ~20mins.

The fix, suggested by magugu, is to edit /usr/mionet/monitorCVM.sh and just below the comment lines at the top (prefixed by ‘#’) add the following:

 

# Start of hack to make Mionet obey startup flag
if [! -f “/etc/.mionet_on_startup” ]; then
 exit 1
fi
# End of hack to make Mionet obey startup flag

 

The fix makes the script look for the flag (/etc/.mionet_on_startup) created by the web interface. The script terminates if the flag isn’t found, but if the flag does exist it will continue as normal (it’s designed to automatically restart Mionet if it is found not to be running)"

*****************************************************

I just used the first solution and my uptime is now 20 days, whereas before it was seldome more than a few hours.

Everything seems to be working fine (apart obviously from Twonky and Mionet, neither of which I am interested in) so I’m reluctant to apply the firmware update in case it breaks something else.

Cheers!