Why was firmware updater unable to see My Passport drive?

I was trying to follow the instructions on the page link below with the eventual goal of uninstalling WD Smartware from my pc. I use Ghost 15 instead. The first step on the instruction page was to download and run the firmware updater. When I tried this, I got the message “No drive found. Please insert a WD SmartWare drive to continue then click Rescan.” Clicking rescan just brought me back to the same message. I checked under My Computer and the My Passport Essential SE drive was definitely there running just fine.

Can someone help sort this out?

WD instructions page


You can try connecting the drive to a different USB port and also updating the drive’s firmware from a different computer… If that doesn’t work… reply to this post with your drive’s model number and I will give you some other recommendations …

@Thepizza > I know you’re happy because I’m back hahaha :)…

I’m wondering whether you have a problem that is similar to the one in the following thread:

Do you have any other USB storage devices, including any card readers in your printer, camera, etc?

Which devices do you see with Microsoft’s UVCView utility?


Which devices do you see at the following registry key, or whichever key is appropriate for your OS?

Tried another port no luck. Don’t have another computer to use that method. Note sure how to find the model “number.” I just know it’s a My Passport Essential SE.

I looked in that registry location but there was no SCSI entry. I read that other thread and don’t think it applies here. There are no other USB storage devices attached. I ran that little utility you recommended (VERY handy) and here’s what it told me I have:

Four universal host controllers, one enhanced host controller, a USB Human Interface Device, my NETGEAR WG1113v3 54Mbps Wireless USB 2.0 Adapter, and one USB mass storage device (‘My Passport 0730’).

Is WD’s Data LifeGuard able to detect your drive? If so, then that would beg the question, why one WD utility and not the other?

BTW, UVCView would be reporting a serial number in ASCII hexadecimal format. This will be the serial number of the drive inside the enclosure.

For example, a serial number such as “WD-WCAV12345678” would be reported as “57442D574341563132333435363738”.

You can decode your own serial number by using Debug in a Windows DOS box, as follows:

-e 100 57 44 2D 57 43 41 56 31 32 33 34 35 36 37 38
-d 100 10F
12EB:0100 57 44 2D 57 43 41 56 31-32 33 34 35 36 37 38 0C WD-WCAV12345678.


The drive’s serial number or model number will be extremely helpful. I’ve included some links on how to get both:

Model number:


Hope it helps.

WD’s Data LifeGuard does not show up on my installed programs list.





What next?