Why the downgrade to 1.03.10 is not recommended?

Did anybody here tried to downgrade to 1.03.10 and then had bad issues?

What issues you had with downgrade to 1.03.10?

I am running 1.03.10. I upgraded it from out-of-box version (can’t remember which).

I am using it to play MKVs, 1080p and 720p,  from WinXP share, 1Gb wired, and everything plays perfectly - no stuttering, no hangs, no problems at all.

So, I can say that for the only puspose playing the mkv files, the WDTV Live SMB v1.03.10 is perfect.

In fact, my only complaint is not-persistent RGB High Colorspace setting. Every time I turn on WDTV or TV, I have to:

Setup --> Audio/Video Output --> Video Output --> HDMI

      --> Display resolution: Auto

             --> Colorspace: RGB High

                    --> Match video framerate: On

Only in rare cases, every some files, Match frame rate fails to match - in that case, set it manually.

The way it is written in the KB article implies that there is an issue with the downgrade process and not with the firmware itself (minus the part that performs the downgrade).

Yes, I’d read that, but I am asking what actually could go wrong - will the WDTV be “bricked”?

Can it be then upgraded again to undo the “damage”?

Nobody never did it? Maybe somebody did it and then he/she had to return it to shop?

No one knows.  Other people have done it with no issue.

And if something’s “BRICKED,” then no, you cannot fix it.  It’s a brick.

I’ve downgraded to 1.03.10 and the only thing I see is that the “Match Framerate” option is missing. So now I’m back on 1.06 firmware. But this is also a no go for me. Video_ts or video-iso stutter every 20-25 minutes for a couple seconds and there’s no way I can play the “Bird scene” stutterfree. I play al media from usb2 and usb3 external hd’s.

What bird scene? The bird scene files I have downloaded range from 20-90 mbit (SMP stuttering starts at 50).

@Tech Flaws.

When I take the Planet Earth Bird Scene in Bitrate Viewer I get following info:

Bitrate in seconds max 33 but  in biterate in frames max 89.

Like I said, no matter how i set up the SMP I can’t play it stutterfree. 

Zwaarpoot wrote:

I’ve downgraded to 1.03.10 and the only thing I see is that the “Match Framerate” option is missing…

As I said, I am running 1.03.10, and I can tell you that “Match Video Framerate” option is present. I am using that option all the time.

Well I’m back on 1.03.10. Did the following steps:

  • Reset to factory defaults (1.06)

  • Skip setup

  • Rolled back to 1.03.10

  • Skip setup

  • reset to factory defaults

  • setup

And guess what … I’ve got the “Match videoframe” option but more important I can play the birdscene (Planet Earth part 1) stutterfree with the option on or off. So I think this time the rollback went flawless.

Hi.

Where i can get the 1.03.10 firmware for WDTV live Streaming??

Thanks.

comodus00 wrote:

Hi.

 

Where i can get the 1.03.10 firmware for WDTV live Streaming??

 

Thanks.

The link is “unlisted”, but still alive:

http://download.wdc.com/wdtv/Rollback_wdtvlivegen3_1_3_10.zip

Official downgrade web page:

http://wdc.custhelp.com/app/answers/detail/a_id/5860/~/how-to-roll-back-the-firmware-on-a-wd-tv-live-hub-media-center-or-wd-tv-live

No stutter ??  Firmware 1.03.10 here I come…

Thank you for the Link location to 1.03.10… I just got the unit last week and was playing fine. I ignore the update until today and all when to “H.e.l.l”.

All better now that i’m back to original firmware.

Thank you.

Because it new revision of the SMP “-01” (P / N: WDBGXT0000NBK-01, P / N: WDBHG70000NBK-01) appeared after the release of firmware 1.3.10 and could not be tested on it.

I did the downgrade, it worked fine, 3 things I noticed are: it appears as 2.03.10 in the “New firmware detected” screen. When you do the downgrade, it will show 1.03.10 but still detect 2.03.10 on your usb key. I think the problem is the .ver file. Second, the accuweather app doesn’t let me chose Ottawa, ON as my city. Third, which is the worse of all, is that I can’t see any of my NTFS (Windows 7) shares. Is there a workaround for this? Thanks!

It’s not a problem with the ver file, it’s the only way to trick the SMP into accepting it as a newer firmware despite being an older one.

hp9000 wrote:
I did the downgrade, it worked fine, 3 things I noticed are: it appears as 2.03.10 in the “New firmware detected” screen. When you do the downgrade, it will show 1.03.10 but still detect 2.03.10 on your usb key. I think the problem is the .ver file. Second, the accuweather app doesn’t let me chose Ottawa, ON as my city. Third, which is the worse of all, is that I can’t see any of my NTFS (Windows 7) shares. Is there a workaround for this? Thanks!

I did not do downgrade due to the fact that I have a model WDBGXT0000NBK-01.

Please report on what model of SMP you do a downgrading.

PS: Number of the model and revision is located at the bottom of the device.

Hello,

i dared the downgrade today and everything went fine. My smp live model is WDBGXT0000NBK-01.

I used the short guide from “Zwarpoot” on the first page of this thread. 

WDBHG70000NBK-01

It’s not a problem with the ver file, it’s the only way to trick the SMP into accepting it as a newer firmware despite being an older one.

Never thought of that, good idea!