Why has AFP (Apple File Protocol) been disabled in OS5?!

Hi, I own a PR4100 and have always used mac machines via AFP to access the server. I reluctantly upgraded to OS5 as I’ve heard that it’s been riddled with issues, but to remove such a vital feature like AFP is absolutely inexcusable. SMB does not work correctly on Macs, it incorrectly displays file names and folders and litters the file system with temp files.

How do we downgrade to get AFP back, this is an absolute joke!

Do you have the AFP Service option in the My Cloud Dashboard > Settings > Network > Network Services section? If so, is it enabled?

No, unfortunately this option has been removed on OS5.

Apparently you will need to use SMB instead then.

My Cloud OS 5: macOS Time Machine “Backup Disk Not Available” or Finder "Connection Error"
https://support-en.wd.com/app/answers/detail/a_id/32003

Apple File Protocol (AFP) is no longer supported on My Cloud OS 5 firmware 5.19.197 and higher.
For more information, please refer to My Cloud OS 5 firmware release notes

  • TimeMachine Backups must be reconfigured using Samba (SMB)
  • Connections to shares must be reconfigured using Samba (SMB)

How To Map a My Cloud or NAS Device on macOS
https://support-en.wd.com/app/answers/detail/a_id/24148

Edit to add: Unofficially and entirely at the users own risk one can try to roll back to the OS3 firmware then roll back to an earlier version of the OS5 firmware (if one can download earlier versions of the OS5 firmware earlier than 5.19.197). Some past discussion on rolling back the multi bay My Cloud models.

I’ve found the same thing. It’s completely inexcusable to remove this perfectly working AFP and tell Mac OS users to go deal with SMB. So pissed at WD.

The problem as pointed out is in fact My Cloud OS Firmware 5.19.117 removes AFP (Depreciated Netatalk service) instead of letting the user choose to continue using it or not (probably removed for lazy “security reasons”).

I’ve successfully rolled my PR2100 back to My Cloud OS Firmware 5.18.117 by downloading the firmware file here:

https://downloads.wdc.com/nas/WDMyCloudPR2100_5.18.117_prod.bin

Save this file as who knows how long this will still be available on their website.

Manually installing this firmware is easy by going to the Settings Icon tab on the far top right of the main page then Firmware Update/Manual Update/Update From File and then select the previously mentioned download WDMyCloudPR2100_5.18.117_prod.bin on your drive. Then turn off Auto Update.

Do you know where I can get the PR4100 version of this firmware? Thanks in advance!

EDIT: I just replaced the ‘2’ with a ‘4’ in the URL and that worked. Thanks again

I certainly understand your frustration with the removal of AFP from OS5. I did a quick web search on “Netatalk deprecated” and found this:

So, if AFP was deprecated by Apple at least two years ago, why is it unreasonable for Western Digital to drop support for it, at some point? Of course there will never be a “good” time to do it but it’s also not reasonable to expect Western Digital to continue supporting it indefinitely.

I understand the issue and its a bummer that WD hasn’t done a better job at supporting the MAC OS community. I upgraded into this issue this morning unknowingly causing a massive File Name Error. Basically it boils down to we have a bunch (thousands) of folders with characters that are acceptable to AFP but not to SMB.

I found is simple IF you know this will happen before upgrading. I could have simply run a renaming software and remove or replace the unacceptable character.

Now can anyone help those of us that found this out too late that?

1 Like

I’ve managed to change a bunch of file names by connecting to the server via FTP. In my case I know the main character causing the issues are ‘/’ and ‘’. Using a file manager (Folklift 3) I ran a search query for ‘:’ which is how /'s are displayed via FTP. I then used the native renaming feature on the Forklift 3 to change the character to a ‘-’.

This is an imperfect solution though, as I’m struggling to get it to search the entire drive. It times out after a few seconds and is generally quite inconsistent and it often threw up errors. It’s not made for searching through 10TB’s of data from millions of files. There might be a better file manager out that what would bypass these issues, but I’ve also tried Transmit 5, with similar results (if not worse).

Another issue I encountered, which will be more difficult to resolve, is that there are quite a lot of files and folders with spaces on the end of them, which causes the same scrambling to occur on SMB. You can’t run search queries for these, as far as I’m aware, so I have no idea how I will automate a name change for this.

It would have been nice is WD would have warned it was turning of AFP well in-advance, or built some sort of tool to facilitate the transition. Simply stating on an update changlog that AFP is being removed, without warning users of the ramifications of doing so, is not enough.

I’m on an EX4100, and the thing that keeps happening for me is that I cannot dupe or copy/paste files using SMB.

While I can understand wanting to have software be future-proofed for upcoming changes, these are expensive units that are usually used by folks who have actual work to do. Folks like us typically don’t do OS or hardware updates as often as regular consumers, because once a system works, changing it is ill advised. For me, all of my video data is on this drive and it is sealed from the internet; therefore, network security issues are minimal.

What’s more, I’ve noticed that when the drive starts acting up – giving errors that it didn’t before, for instance – it means that I need to upgrade firmware, which is annoying. I will be looking to make sure the “My Cloud” function of the device is turned off, as it seems like the hard drive, which I do not need attached to the cloud, is in fact accessing WD’s servers in some way.

I think what folks are trying to say is, we’ve paid a premium for this hardware tool, and would like to be informed of major changes before we update firmware, especially if it will be difficult to debug and roll back. This is OUR data, not WDs, and if the workflow functions, we don’t want it to change unless we choose to. Our income depends on having that info.

Also: for the link provided, I’ve found when I substituted my model number (EX4100) in for the one in the link, I was able to get the correct file. I see that tiagocoelho was also able to do this for theirs.

I am currently regressing the unit, and it’s rebooting

Wish me luck!

update: regression worked! and the problem of duplicating files is solved!

BTW, another reason this change is so galling is that just a month before this change, I sent in a request to correct the file dupe problem, the CSR recommended using AFP instead of SMB. Not once did they mention that AFP was going to be removed.

I can forgive the CSR for not necessarily knowing, but WD should be training all of their folks in such a way so that when someone is SPECIFICALLY telling a customer to use a soon to be deprecated feature, to warn them no to update their firmware.