Why dubbel navigate?


I have hade the WD HD TV and WD HD TV Live (Gen 1 and 2) and thay have worked okay. No I have bought a WD TV Live Gen 3 but have some problems : 

  1. The WD TV Live is register alot of dubble navigations, so If i push down the arror down button its common that the marker will jump at least 2 steps down? This is vary frustrating becouse there is also a lag, so if I fast puch down and then OK to start it might start the post that are 2 steps down with a dealy of 1 sec?

  2. Every time the unit is starting it will state 0 videos and then begin to scan my internet chare(LAN cable). It take a lot of time until I really can start the vide? 

  3. Some times when starting up it will only show parts of the screen on the TV?

Note : I have tried the reset button and this made the WD TV a bit faster but its still laggy and the duble click is really annoying.

Do I got a defect unit?


What firmware are you running on the unit?

Have you tried resetting the device?


It is running 2.01.86 and I have tried reset.

I was at the store today and got it switched. The new one are a bit better but still far from okay, there is a lot of lag with the remote. When connecting a keyboard the response is much better.

It is also really slow to startup.