Why does My Passport Essential SE external USB HD freeze PC at boot?

I got a My Passport Essential SE for one thing: To give Ghost 15 a place to back up my C drive on Sunday and my D drive on Monday. I figured I could leave it plugged into the PC all the time and when it was time for Ghost to do its thing, all would be groovy. Usually my Windows XP Pro SP3 is turned on all the time, but I had to reboot one day because of a software update. When my PC got to the very first step of the boot procedure – where it shows the “Intel Inside” image stored on the motherboard – it just stopped. No activity on the hard drive, no nothing. Using my Symantec recovery disk didn’t work either, apparently because the boot process wasn’t going far enough into the procedure to where it reaches the point that the BIOS realizes the CD drive with the recovery disk is the first place it’s supposed to boot from. Numerous shutdowns and restarts failed. Took it to the repair shop and it worked fine for them. The reason? Nothing, including the My Passport, was plugged in. So I took it home and experimented. Booted without My Passport plugged in. Then plugged it in after everything was up and running made sure no software like antivirus or other was pointed at it for any reason. Went down to the “Safely remove hardware” icon and selected the My Passport and clicked the Stop button. Tried it several times, but always got the same message: “The device ‘generic volume’ cannot be stopped right now. Try stoppig the device again later.”  Any ideas what’s going on here? Yes, I’ve installed all the lastest firmware etc for the My Passport. Why does this external hard drive kill my boot process?

Hello freind the reason the computer hangs during the boot is beacause of the VCD on the drive. Its no different from when you keep a cd rom in you cd drive the computer depending on your boot order will try to boot from it

The best option Is to disable the boot from USB in the bios here are the instructions