Why am I on "relay" connection, not "local" connection on Win 10 PC?

I’ve had my 8TB MCH for about 4 days and find the whole experience very frustrating! I’ve read lots of posts and KB articles, but they all seem to go to a dead end.

I have a Win 10 desktop, Win 10 laptop, and an iPhone 10. All have the WD Discovery web and mobile apps as per.

The MCH and desktop are connected directly to a BT smart hub with UPNP enabled and all ports 1GB/s. The WD Web app on desktop shows connection type “relay”. I would expect it be “local” as they are joined via the router.

I’m seeing painfully slow tranfer speeds between desktop and the ‘private’ mapped drive, considering I have TBs of photos to sync. Since 4 days, it has not completed a transfer of 1.3TB of photos, with no apparent end in sight (just lots of little blue ‘pending’ symbols and very few green ‘syncd’ symbols).

I am hoping local connection would speed up the transfer between desktop and MCH and it’s slow because of the proxy relay connection. (public share is very quick when drag&drop, over 100MB/s compared to 20MB/s to private share)

Bizarrely the iphone when on the home wifi shows connection type “local”, but both pcs show “relay”.

I turned off the Norton firewall on the desktop and rebooted MCH and made no difference.

I previously used a 4TB MC and Synctoy and had no speed issues. This MCH seems a big step backward in user friendliness and functionality.

I just want fast sync of the folders, and the means to use my phone / laptop when on the road


User Manual: My Cloud Home and My Cloud Home Duo (westerndigital.com)

Thanks cat0w, I have the manual already and don’t see where it references the solution to my issue.

In short, why does my iPhone show as local connection (when on home wifi) and the desktop/laptop PC show as relay connection?

Does this have an impact on transfer speed?

There is no information on this in the manual. All I found is a web guide saying to ensure my router has UPNP enabled, which it does, but right now all my devices are on the internal connection!

Here’s the config

On PC connected directly to router

On iphone when on wifi by same router

Why is the PC not showing local, when it’s connected directly to the same router as the MCH? They’re in the same IP subnet internally 192.168.1.xxx and i’ve set the router to reserve the IP for the MCH

I also see no way of knowing the sync progress on the PC, as it seems to have hung up. The HDD sourcing the files is showing read speeds in Performance tab of Task Manager of between 100kB/s and 4MB/s. So I assume it’s doing it. wdsync.exe is showing CPU usage. Do WD expect us all to be familiar with this to know what’s going on?

relay connection and direct connection - Google Search

@cat0w I appreciate the replies, but it’s guiding me to stuff I read already and not the solution to my issue.

The computer and MCH are on the same LAN, so how do I make the connection = local when it’s decided automatically by the web app running on my PC? What is making the app think it is not on the same LAN as the MCH?

I am not connecting via VPN. That would be the only viable explanation, but I am not on a VPN.

Port forwarding and UPNP should make no difference as I am not connecting remotely, the MCH and computer are about 4 feet apart and connected to the same router by cables and are on the same IP subnet on the internal network.

The iphone on the same LAN proves a local connection is the type I should be seeing.

I have disabled Norton firewall on the computer and rebooted the MCH. No effect.

I believe until I can get a local connection, the transfer speeds are pathetically slow and unacceptable to the point I will return the unit to WD for a refund.