Why 3000GB(WD30EZRX) does not work with XP SP3 32bit? but Seagate can?

Why 3000GB(WD30EZRX) does not work with XP SP3 32bit? but Seagate can?


I have been using WD hard disk over ten years, I have just bought 3TG WD30EZRX and toss about it in XP for few days, now I even can’t restore original factory settings as 3TG unpartitioned status, I tried all the partition softwares…
Obviously, the WD green 30EZRX 3TG hard disk is technically immature.

I have found a post about WD 3TG problem on  http://forums.whirlpool.net.au/archive/1998232

…Acronis Align Tool will not make Windows XP see the whole 3TB hard drive because it’s a simple fact that Windows XP does not support a GUID partition table. Doesn’t make a difference if the motherboard has EUFI when you’re running a 32bit operating system.

Is that right? are there any software to fix the problem that let user to use the whole 3TG WD HDD in XP 32bit?

There’s an article that explains this OS limitation.

Hard drives greater than 2 TB do not work on existing operating systems


I tried to use Windows XP 64bit and Windows 7 to partition WD 3TG, but still can not partition it, it keep showing there are only 746GB. After I use Windows 7 setup disk to delete all the 3TG partitions, but still, there are only 746GB. I think that the WD should tell user how to restore original factory settings, which is raw unpartitioned 3TG, any particular software? Acronis for WD Partition does not work at all.

I have used the following software to partition WD 3TG:

Acronis Disk Director Home

Acronis WD Align

Acronis for WD Partition

AOEI Partition Assistant



All failed.

And it’s so funny, I found the WD 3TG now showing that it becomes 4057.99 GB! 

You could try using a HD capacity restore tool.

Try searching online.

I think it might also be posted on this community but I can’t find the link know.

Did you try a Quick Erase (write zeroes) in Windows Data Lifeguard?