White light

Hi, i haven’t used my cloud in a very long time. When i tried to connect the device it doesn’t work. my network can’t find the device. The LED light is white. I have tried to reset the device, but nothing happens. Does anyone have any advice to give me?

Is the My Cloud connected directly to the network router using an Ethernet cable?
Is the computer also connected using Ethernet cable to the same router?
Is the router handing out an IP address to the My Cloud device?
Have you tried a 40 second reset?

In certain rare instances the broadband provided network router can cause a conflict with the My Cloud. The workaround is to put a network switch between the My Cloud and the network router.

If using Windows 10 ensure SMB 1.0 is enabled as Microsoft has disabled this option in recent Windows 10 updates and in new installs of Windows 10.

Yes my cloud is connected to a router with an ethernet cabel. My laptop is connected to the same router without the ethernet cabel. I have tried the 40 sec reset, but my cloud doesnt respond to that. I tried to check the router if my cloud have an IP address, but i didnt find any.