White light stays on

I recently tried to access my drive and an error came up. Looked at the drive and it had white led light. Looke it up and it said firmware updating. I don’t use the software so I don’t have the dashboard I access through my computer. Apparently the firmware was updating by itself. It has been white for a day. I went to network connections and deleted drive and tried to reinstall the drive. It doesn’t show up now. I went to another computer connected to my router and tried to access the drive and got the same message. Everything is connected with wire (no wireless connections). I’ve treid resetting the drive, I’ve tried turning it off, then back on. It always goes back to white. I have files on there I need. Once I get these files, I’ll trash this drive and won’t buy another WD drive again. I have an IOMEGA and a Fantom drive and they have worked flawlessly for over 2 years. What is the problem with this drive?

I had one that I dropped off a table by mistake and was doing the same thing. You should be able to access the Dashboard (to see whats going on - no software is required) through any web browser - go to http://DRIVENAME/ or http://IP_ADDRESS/ and it should come up - if not than there is either a network issue (something like an over-agressive firewall, or other setting that is blocking access - this is unlikely but always good to check before replacing the dirve), or an issue with the drive. Your drive should still be in warranty (unless you’ve opened it up) as they only started making these a year or so ago… I’d give technical support a call and see if they can’t help you determine the problem, before replacing the drive. – By the way I now own 5 of these and with the exception of the one I broke myself, they have proven to be one of the best NAS’s I’ve ever purchased.