Where's the bass?


#1

Ok…so I’ve been noticing that there seems to be little to no bass pushed to my system from the Live TV. I’ve got a Harmon Kardon amp & sub, which rocks hard core…but even with volumes near max, I’m getting almost no bass from the sub- it even turns itself off during action sequences. Anyone else notice this? Also, it seems that the center channel level is WAAAY low- I have it jacked to the roof and I’m straining to hear it. The satillite speakers are just cranking though- effects and music are way louder than the dialog. I’m playing back the same media that my PS3 does…I can accept that the PS3 might have a better sound processor, but i can hook a 30 dollar MP3 player to this system and it still sounds like a million bucks.

Also- firmware suggestion- give me the ability to disable audio over HDMI! What’s the point of directing audio over optical AND HDMI?


#2

i thought you were talking about fish, just kidding…

i might be wrong, but bass and most audio functions will come from your amp/receiver.

the WDTV shouldn’t affect it.


#3

Yeah, I know it shouldnt- but it sure does. I know my way around audio gear (and more than my way around tech), and the Live TV is the only difference. If I flop my HDMI switch to my PS3 and play the same file over optical input 2, I got that boom boom boom. From the WD, nada…


#4

What format is the audio ?


#5

I just confirmed- it looks like the “.1” in “5.1” isnt functioning. I moved the subwoofer input from the “Line Level in” input to the “L” channel on the sub, and then switched my reciever to std sub out rather than line level. Now I get bass- but not nealry as strong as it should be. I’m assuming that if I split the sub input to cover the L & R channels I should get the same effect as Line Level…but why the heck doesnt Line Level work with the WD Live?

I’m playing back a .MKV (Queen of the **bleep**)  from a network share- Audio codec is AAC (faac), Mixdown to Dolby Pro Logic II.


#6

You know your way round audio gear and you never noticed that there was no output from the sub-woofer!!


#7

You should start with the basics, and work it up from there.

First of all, you say that you know your way around audio gear, but I’m not so sure. The bulk of the bass present in most soundtracks is in the main channels, so even if somehow the .1 channel (LFE) would have disappeared you would still have plenty of bass in your subwoofer. Just for kicks make sure the satellite speakers are set as “small” on your receiver settings, otherwise bass management will not work.

Anyway. the easiest thing to do test here would be to start with the basics and check that your receiver plays correctly a movie soundtrack when the receiver itself is performing the decoding. Check in the WDTV live settings panel that audio is set as “Digital” instead of stereo, and play a movie with a Dolby or DTS 5.1 track. Make sure that the receiver displays DD or DTS 5.1 and check if there is any weirdness here (lack of bass, uneven volume between frontal and center channel etc… ). If there is, then there’s something wrong with your A/V settings or connection. If that plays correctly but the AAC track still plays weird then you can try other things.


#8

RichUK- Being that I just got my LiveTV a few days ago, I’d hope you would cut me some slack instead of being a tool. Obviously I did have subwoofer output prior to using the LiveTV, as I stated in my original post.


#9

Billstpor- I will verify my speaker size settings tonight, but I’d be suprised if they changed. My wife likes to push buttons, but that’s a long way down into the menu. Thanks for responding…


#10

No go. I checked the speaker size- and tried every different arrangement I could think of. It was previously set on Large, with the sub type set to LFE/LR. I set them to small, and then the only option the menu gives you for the sub is “sub”. No love on that either. I changed it back to “Large”, and then set the sub to just “LFE”, and still no dice. I even did a hard reset on the receiver, which is known to correct some other issues.

I watched the receiver a little more closely- and it definitely looks like it’s not seeing the WD’s playback as 5.1. Normally when a 5.1 source starts, the receiver flashes “3/2/1” to indicate all 6 channels are active. I get no such indication when the WD starts up, or even starts to play a movie.

Just to recap- using the same exact file from the same exact thumb drive and audio sent over the same exact optical input, my receiver recognizes the PS3 playback as surround sound- but the WD is processing in stereo. I am having a hard time believing that there’ s something amuck with my audio set up. I’m more inclined to think there’s some incompatibility between my ripped movies and the WD, or the WD and my receiver. 

I’m going to try re-ripping another movie and swapping around some of the audio options. If all else fails, I’m going to bring it back to Best Buy and wait for the Boxee Box. So far this endeavor has been a real  time vampire.


#11

I’ll be upfront-I’m no super techie but at least means I won’t be condecending. Some times the overlooked is the obvious-er maybe!! It does state that you must use the optic connection for surround sound, not the wired as it is only stereo. I find this er interesting as I have wired + coax on my surround “system” but no optics and it still seems to work. Maybe mine is a pseudo? setup but seems to work as well as using DVDs. Just a thought-what do you think/possible?


#12

OOOPps- loking at the post before it seems you’re using the optical.Ah well that’s my fame shot down :slight_smile:


#13

Update- I re-ripped Gone in 60 Seconds, and this time set Handbrake to rip audio in AC3 passthrough. Now my receiver shows I’m getting Dolby Digital and is in Pro Logic Mode. All 6 Channels are lit on the receiver- but I’m STILL not getting any audio over the LFE. It sounds “OK” plugged into the analog sub input…but not as good as it should.

I think I’m going to move this box into the bedroom (there’s no system in there, just using TV audio) and wait for a Boxee Box for the living room. The Live isnt a bad unit for the money, but I do have a few complaints- sometimes there’s a crazy long delay between command and execution in menu navigation, it looks like the firmware track record isnt exactly great, and then there’s the issues I’m having with sound processing. 


#14

I honestly think there’s something wrong in your audio setup, because what you are saying doesn’t make a lot of sense. You say your  rip with AC3 sound displays as 6 channel but with the Dolby prologic mode. Unless you have a 6.1 or 7.1 setup you should only see “dolby digital”:  prologic only kicks in when you play a track with less channels than connected speakers. It looks like you still have the WDTV audio output set to “stereo” instead of digital, you need to check that to make sure you are not downmixing everything to 2.0 (and the receiver is expanding it to 5.1)

One thing is for sure: the WDTV needs to decode AAC before sending it to the receiver, but when set to “digital” it passes through any DD or DTS tracks just as any other device would, so you can be sure that it isn’t “tainting” the sound in any way, right after the data reaches the audio input of your receiver and it shows as “DD 3/2.1” it is absolutely the receiver’s fault if the bass management is screwed or the levels aren’t right. If the PS3 sounds different with the same file, then either of them is not bitstreaming the data, plain and simple, or you have set the receiver to process that digital audio input differently than the other one, but certainly the data was the same when it reached the unit. I don’t own a PS3 but it wouldn’t surprise me if your PS3 was set to decode the audio and applied some kind of equalization or 3D mode (like stadium, rock etc…) before sending it as PCM, or your receiver applied it to that input only.

Another thing: you mentioned in your first post that you had “satellite” speakers, yet you say you had set them up as “large”. Now I don’t know if you meant that all your main speakers were satellites or not, but if they are then you are setting them utterly wrong. Setting the speakers as “small” or “large” doesn’t depend on the money they cost you, or that they don’t blow up when you set them as large, it depends solely on the diameter of the drivers. If they are satellite speakers you have to set them up as “small”, as simple as that. Messing this up means messing up bass management, and could well be part of the reason why the system ended up with the wrong calibration. If it weren’t for the “LFE+left” setting you wouldn’t hear almost any bass btw.

To sum up, you should set your receiver to “small/sub”, the WDTV audio output as “digital”, and check your PS3’s audio output too (whatever it is) to make sure it isn’t applying any decoding/postprocessing. Then you can calibrate the levels properly and hopefully everything should sound exactly the same…

Here are some 30s clips I got from “Inglorious **bleep**” with different sound codecs if you wanna test sounds in different modes (DTS 5.1, DD 5.1, DD 2.0, etc…).

http://www.megaupload.com/?d=CEBGKZFM


#15

Bill-

I did try the mains set as small, and then the reciever forced the sub setting to just “Sub”. I still didnt get anything from the sub’s Line Level input (which I understand is my receiver not pushing audio out).

I think I might have confused you with my last post…to clarify- with AAC passthru turned on when I rip, the reciever DOES say “Dolby Digital 3/2/1”. I can accept that I need to turn passthru on in order to get the receiver to really process in Dolby Digital- that part makes sense to me.

What doesnt make sense is that when my PS3 plays the AC3 pass-through rip back and the receiver shows “Dolby Digital 3/2/1”,  and the Line Level input on the sub shakes the room. When the WD box plays the same media back, the receiver also kicks into Dolby Digital 3/2/1, but I get nothing through Line Level on the sub- as a matter of fact, the sub wont even power up (I have auto-on enabled).

I guess I could believe that there could be something wrong (like broken wrong) with my receiver’s bass management…but I’m still struggling to wrap my head around why the PS3’s digital output would work with my receiver, but the WD’s wouldnt. I’ll take a look at the PS3 tonight and see if I can figure out what it’s doing. I’ll also try your rips with the mains as small and sub as “sub”.


#16

One of things that I don’t understand is why your receiver says you are receiving Dolby Digital and it is Pro Logic Mode. These are seperate modes. You have Dolby Digital which gives completely separate channels and Dolby Pro logic which is a matrixed stereo mix. You also mention that you were originally playing back a .MKV (Queen of the **bleep**)  from a network share- Audio codec is AAC (faac), Mixdown to Dolby Pro Logic II. Again Dolby Stereo matrix mix.> However regarding your original question as to the lack of subwoofer output, the answer to that is gained by reading the Handbrake guide which says “Be aware that, due to technical concerns, Dolby Pro Logic II is currently created as 5.0 sound. This means there is no separate subwoofer channel. Adding the sub channel can cause serious distortion, depending on how the DVD’s audio was mastered.” > http://trac.handbrake.fr/wiki/SurroundSoundGuide> Hope this answer makes me less of a tool.:wink:


#17

Yeah, I like that reply alot better…however, I dont know that’s my issue.

If I’m reading that page right, Handbrake strips the sound down to 5.0 only if you use Pro Logic II for the Audio Codec. In my latest effort to get LFE output, I’m using AC3 Passthrough, with the DVD source being AC3 5.1ch. That should be copying the soundtrack bit-for-bit- including the subwoofer channel…


#18

i would go here and get an ac3 5.1 video to make sure that the problems isnt caused by the source file (encoding problems, etc)

http://www.demo-world.eu/trailers/

btw, you initially tested with an mkv that contained aac audio…is your receiver able to decode aac?

anyway best to test your sub/bass issue with a file that has 5.1 ac3 audio…

good luck


#19

Are you outputting your files from Handbrake as MP4 or MKV?

If MP4, try using an MKV container instead.

I did a little experiment with my setup after reading this thread.  My old Pioneer DD5.1 amp’s display lights up to indicate when the digital signal has 5.1 channels, plus an additional dot beside the LFE channel icon flashes on whenever the bass signal is active.

With all my MKV files that have 5.1 AC3 audio (and my AVI files with 5.1 AC3), all the 5.1 icons light up and the LFE channel is present and working. 

With an MP4 container with AC3, it does not register that there are 5.1 channels and seems to downmix to stereo.

I’ve even de-muxed a non-working MP4 and created an MKV using the exact same streams.  The file then registered on the amp as having full 5.1 channels, LFE channel bumpin away nicely.

Another example:  MP4 with 2 AAC audio tracks (Stereo and 5.1 Surround).  Both tracks play through the amp in stereo.  

When muxed into an MKV, the stereo track plays fine as expected but the surround track does not play at all, again as expected because it’s an old amp and can’t handle the outputted AAC surround signal!

It seems that the current WDTV Live firmware has multiple issues with the MP4 container, not just the audio sync issue.  :|

-edit-

Using eac3to I was able to recode the AAC surround track to AC3 within an MKV, which then plays perfectly on my system (bass REALLY pounded during a random action scene, I had to turn it down).  Here’s the link if you want to try it:

http://www.videohelp.com/tools/eac3to

It would be nice if the Live could output AAC as DD5.1 or PCM, most HT setups can’t handle AAC AFAIK?  There’s an idea open in the Idea Exchange if you want to give it some support:

http://community.wdc.com/t5/WD-TV-Live-Ideas/Live-decoding-AAC-5-1-gt-PCM-5-1/idc-p/824#M165

But you’re absolutely right that the WD TV Live is a time vampire.  :)  Can’t just play a file, especially not an MP4, without remuxing, recoding or faffing around with it in some manner first.  I have to plan ahead what film to watch so that I have a properly rigged MKV ready to play; my wife hasn’t the patience to wait for me to monkey around with a file when I realise it’s one I haven’t fixed yet.


#20

Just so there’s no confusion, here’s a screenshot of my handbrake settings.

Handbrake Settings