Where is this password?

When I want to access my MyCloud device as a drive in a normal Windows Explorer window, In Windows Explorer under Network I double click on the WDMYCLOUD icon. I get a log in for a user name and password.

I tried all my normal logins including the one I set up when I use the WD My Cloud software I downloaded as well as the web portal but that doesn’t work for this Windows log in. When I use those two methods (software and web portal) I can get into my drive but I don’t like the interface. I want an interface that looks like any other drive in Windows.

Fortunately I found a username and password that works (the user name is Administrator) but it is an old, irrelevant log in that may have been on my previous computer. I’d like to change this log in but I can’t find anything in the WD My Cloud software or the web portal that seems to pertain to this. If I didn’t happen to have tried that user and PW combo I’d be out of luck.

How can I change this? Or better yet get rid of it? I really would like to minimize security and the need for logging in.

Hi there William:)

Did you try to set up new user in web dashboard and then log in with that credentials? also I dont think you can remove the Administrator account as simply its administrator… maybe if you could login into the web dashboard under the administrator credentials you might be able go to users and delete the user (not sure as I never had an Administrator acc on my NAS)…

Is this asking for a network password, if yes, use your user name and password you created when you set up your router.


To investigate, I established that neither my router or my computer currently have a user or account called Administrator.

Then I unplugged the MyCloud. After a few seconds, I got this:

I restored power and waited until the LED on the MyCloud was steady and the WDMYCLOUD icon was back on my computer, as shown here:

I discovered to my surprise I could still connect to WDMYCLOUD by double clicking. I was actually hoping it would make me log in again so I could show you what the log in looks like. But yes, I think it is a Windows Network log in. But I have no idea where Administrator lives. My OLD computer DID have a user, and I think I used that old computer when I first set up the MyCloud (which has been on the shelf for several months). I think it is the MyCloud device that “remembers” the user Administrator.

But as I mentioned, I can find no sign or trace of Administrator anywhere (such as the web interface to MyCloud). If I did not happen to have tried Administrator and OldPassword I would not be able to open up the device in Windows Explorer.

I am hoping that you guys can help me figure out what is remembering Administrator and exactly where the memory of it lives and hope I can tell it about other users or delete it or otherwise manage the situation pertaining to it.

oh right so the Administrator is from your computer… I thought Windows is asking you for credentials of your nas… well then… here is the thing… does the user you are currently logged in on Windows have administrator rights? it might be that you are logged in as a user and you need administrator to allow you connection to network devices… Administrator Account doesnt show up when you want to login after booting up… this is due to security… if you would boot your computer to Safe Mode (holding F8 while booting) you would see user named Administrator… and by logging in you can then promote your user to Administrator and remove the old Administrator Account…

hope it makes sense :slight_smile: if not I can make it simple for you:)

I cannot seem to disconnect from the MyCloud now…I’d like to disconnect so it forces me to log in again so I can investigate and take screen shots. Do you know how I can disconnect?

did you try to boot your computer into safe mode?

Let me put that aside for now and answer some of your other questions. For several reasons I don’t want to shutdown or reboot at the moment.

I am an administrator named William. So I went into Control Panel, Users and I enabled the Administrator account and set its password to be the same as the password I had to use to connect to the MyCloud.

Does this now enable me to administer the account that pertains to this Administrator account that MyCloud is concerned with? And how can I disconnect the MyCloud device without rebooting or using safe mode?

If you can get to the Dashboard use shutdown or reboot. See image below.

If you have WD Quick View click on it, point to WD My Cloud and choose shutdown.

When you go to My Computer you should be able to right-click on the WDMYCLOUD and there might be an option to “disconnect” or “dismount”… i am not sure as I dont remember WIN 7

I discovered I can connect via an Explorer Window (not a browser) on a different computer by typing in \wdmycloud.

My original objective seems to be fulfilled but thy mystery of where that Administator password lived is getting murkier.

In the course of things I had disabled all security. This probably means someone who gets on my router can invade.

But I have to stop this and write a program for my job. It is unethical for me to keep at this MyCloud mystery. I will mark it solved but the fact is I am puzzled by this whole thing. Thanks for your time.

I am 60% positive that its the Administrator account that shows only in safe mode :)…

If you will want to come back to it later… no problem :slight_smile: we can pick it up any other hour or day :wink: I know I hate leaving something undone :smiley: