Where is Flingo in 3.05.10

Updated to 3.05.10 and now cannot find Flingo section which has TED talks. Anyone have the same problem? or ideas.  How do I get it back?

Try pressing the reset button on the bottom side for 1 second, if that doesn’t work try rolling back to the previous version and then reinstalling the latest version again.


Thanks for the prompt reply Alucardx.

I should say I have two of these devices both with the same update and both have the same problem. So this is not isolated to just one device.

I tried resetting without any luck.

I downloaded 3.04.17 extracted to a USB and when the menu comes up hit cancel as instructed but there is no Firmware menu as indicated in the instructions. I tried several USBs and eventually a new one but no luck there is no firmware menu.

The same problem exists on the second device and I am believing it must be a firmware issue. If this were the case then someone else must have come across this (I would have thought) I can’t be the first I’m never first.

Anyhow still looking for suggestions but think this is a WD firmware issue and hope they are online to advise.

Cheers Dingo


1 Like

Foetus… Thank you

Man o man I feel stupid now.

I looked at everything just didnt see where Launchpad said powered by Flingo. 

All good now many thanks


no problem
I like watching TED presentations