When will the networking issues be fixed?


#1

[rant]

I am getting really annoyed at the networking issues on this box.

I seem to share the same problems as many others here with the three main ones being

  1. Dropping network every 4-5 mins

  2. Network shares just not available

  3. USB drive sometimes not getting recognised, fine other times

I am running a wireless USB dongle (DWA-125), got connected effortlessly - staying connected and being able to play stuff - not so good.

Tried every single option/workaround/network setup I can find on this subject with no luck.

If these problems seem so common, I hope WD engineers are working on a fix

Anybody reckon going to a wired setup is going to fix my problems?

cheers

Mutton

XP SP3 - Biilion 7401 - WDTV Live w/DWA-125

[/rant]


#2

Nope… there are plenty of “bread and butter” networking issues with a wired connection as well.  I cannot understand how WD managed to get the networking so wrong on this device - it really beggers belief !


#3

Strange, never had a single network problem with my WD over a wired network connection using a Linksys.  I wonder if you have an issue with your switch or cabling?  If you are running wireless there could be a myriad of other problems.  Running video (especially HD) over wireless is asking for trouble if you ask me (not that it shouldnt work!).


#4

 I was having the same problem, with a video playing fine and then it lost the network connection.  The problem seemed to be random.  After much trial and error, I discovered this happened every time the second computer on my network made a connection to the internet.  If the second computer is powered on but not accessing the net, the problem does not happen.  But as soon I launch IE8, the connection to WD immediately dies.  It makes no sense because the media I am accessing is not even on this second PC.  The second PC does have a network share that is recognized by WD, but I am not using the share for any media that I play on WD.

I am using a wired network and playing media from network share on a PC running Vista. The second computer on the network (the one that causes the network to drop) is XP.  I am using a Verizon branded Actiontec router, provied by Verizon for access to FiOS internet.


#5

Sunds like an IP conflict problem. Are you specifying a fixed IP to each device? If not, I recommend you do this. Perhaps your router is dropping the WD and assigning the IP to the PC that comes on. Are there enough ip addresses available for the router to assign devices in your network?  (this are just some ideas)…  Al


#6

If there was an Ip conflict it would have gave him an error immediately when the computer was powered on. Your router doesn’t assign an ip to your computer when you open up internet explorer, it assigns it once your nic card is active on the network. To kinda of skip all the steps of what it actually does and to simply put it in a way you would understand, the computer would send a message out to the network asking if there is a DHCP server avaliable. The DHCP Server would respond back saying yes one does reside on this network segment. The client then responds saying it will accept the address assigned in a broadcasted message over the whole network. This will inform all devices on the network that it is being assigned a specific IP address. Thats why people would get error messages if there is an ipconflict. DHCP servers will only assign free addresses unless there is a reservation on it’s table. I can’t forsee the router assigning the same address to your computer and WDTV Live at the same time unless it has the same MAC address which is next to impossible unless you spoofed it considering the manufacture of the nics are different. Eitherway most modern routers should support atleast 50-100 devices so I can’t forsee you using up all your address. To me it just doesn’t sound like an ip conflict problem. Ip addresses are assigned when a computer turns on not when internet explorer is opened.

I can’t give you a definite answer to the cause of your problem and why accessing http would force the connection to drop without looking at the traffic data on your network. In addition by Steve saying that the WD TV Live sees the network share already indicates that they have different ip addresses. SMB uses the TCP/IP suite to to transfer files.


#7

yep assigned all pc’s and the WDTV fixed IP’s, so that’s not the problem.

Might try turning off Outlook and Messenger and see if that makes a difference while in playback.

Will keep trying until the next firmware release which will hopefully improve it.

Also just ordered some wallplates, RJ45 ports and CAT6 cable, going to rule out the wireless issue and cable the house (something I have been meaning to do for some time)

cheers

Mutton


#8

Well I shut down everything that accesses the internet on the network pc’s and I got 58 minutes into a movie this time hen the same

 “There was a problem connecting to the network.  The device could not connect to the network.”

So better but still not great and not consistent either, tried it again this morning and same old story.

Many others are having the same problem across the forums - so will just keep an eye out for a solution that works for me, some firmware and that home cabling stuff in the mail

thanks for your suggestions so far

cheers

Mutton


#9

Guys, it’s not your internet connections, I can tell you that.  On our network I can do heavy internet (downloading and uploading) on two other PCs at the same time I play back a 1080p movie with no problems, so at least you can stop chasing that tail.


#10

No I was thinking it was more the traffic across the wireless network that was the problem with the above issue.

Main pc with media connects wirelessly to router as does the WD, but all only at G speeds, so will put everything to wired and see if that makes the difference

cheers

Mutton


#11

You could be right about traffic – I streamed some stuff to my TiVO box (which is such a heavy load on the network it stops my iTunes from playing wirelessly over the house :>) and it did indeed stop Live (so hard it performed a reboot, which is the first time I’ve ever seen this).

After I stopped the stream everything was fine (and my wife and I watched a 1080p movie, Ponyo, with no problems).  So there’s obviously something to be said there.

For sure I’d try the Belkin FSD8055 wireless adapter – folks living in the U.S. can get it from Office Depot and return it within 30 days for free if it doesn’t work.  I say this because it works for me and that’s at least a known quanitity.  I’ve used other wireless adapters in our house with issues, so it DOES make a difference as to what you use.  If at least one other person who can’t connect consistently tries this we could at least eliminate the adapter as a factor (if it doesn’t solve their problem then it ain’t the adapter).


#12

See my last post on the  “Lost network connect every 5-10 mins.” thread.  I seem to have resolved one problem by separating IP addresses on my network.  I agree that there may be a traffic interaction - perhaps the 5 -10 minute interval might be due to a computer on the network running a program that periodically checks something on the internet, like Outlook looking for new mail. 

Two nights ago -  broken network connections every 5-6 minutes “like clockwork”.

Last night - hours of uninterrupted viewing, no broken network connections. 

The difference - no other computers in the 192.168-0.2 - 192.168.0.10 range. (just the router at its usual).

We can’t be sure yet that this is the workaround - others will have to try, and I’ll have to see more evidence.

But, if the workaround proves out, it just might provided a useful clue to help WD isolate and solve a lurking firmware bug.

Let’s hope.

Dave Straayer


#13

OK, when I have a chance I will change things around and give it a go

Will let you know the outcome

cheers

Mutton


#14

Well sat down and re-assigned all of the PC’s, NAS and PDA to above 192.168.1.20 and left the WDTV Live on auto, which saw it at its previously leased IP of 192.168.1.5

I think you **MAY** have found a solution for me.  I haven’t had the chance for extensive testing yet, that is why I say may have found a solution BUT…

These are all things that were causing me problems which I haven’t experienced since changing the IP’s around.

I can see the Network share almost immediately, don’t have to wait for it to find it, I can access the network share as soon as the WD fires up

I can navigate through it, out of it and back to it, and its STILL THERE

I can Listen to music and look at photos on my network share with no issues, that always used to crash the connection

and have been able to play around 20 mins of movie with no problem, will have to try longer

So if this tests out ok, more people should try it, then where do we go with it?

cheers

Mutton


#15

I have everything on my network assigned a static IP. Maybe i’m missing something, but i don’t see how making the WD IP dynamic would stop the network connection issues. Can someone elaborate on that a little more?


#16

Indisent asks: “I have everything on my network assigned a static IP. Maybe i’m missing something, but i don’t see how making the WD IP dynamic would stop the network connection issues. Can someone elaborate on that a little more?”

Here is my hypothesis.  I set fixed IP’s in the 20’s range.  All the dynamically-assigned IP’s get assigned around in the 0’s.  If the Live did something stupid, like increment or decrement t  its IP address by one, it would bounce around in an empty field of addresses.  All the other computers on the network are up in the 20’s. 

OK, it’s just a guess.  But it is working on my network now.

DHS


#17

Mutton comments “So if this tests out ok, more people should try it, then where do we go with it?”

One, give my posting a star:stuck_out_tongue:

Two, we pass along this info to WD in emails.  If the Live is doing something stupid with IP addresses, and this fixes it, they should be able to address the problem in a firmware update, and we can reset our networks back to however we want.

DHS


#18

If you find something consistent amoung you that you feel fixes or breaks the device, I will pass it along to the appropriate people.  Just let me know.


#19

Sorry to say that although I think it has improved things, it was back to its old tricks again this morning when I tried it.

Looks like we may be half way there, didn’t try restarting the router this morning which was the difference last night, but don’t think I should have to restart my router every time I want to watch something anyway

Will keep tinkering

cheers

Mutton


#20

mutton,

I forwarded this thread on to the product people.